Close

Account

Documentation

Forum

Menu

Youtube playlist does not work

  • Post count: 4
    montevideomarketing
    November 7, 2019 at 11:30 pm #52791

    After the last update it only shows me the first video entered. All other videos do not appear in the playlist.
    image example

    Post count: 6703
    Ferdy
    November 8, 2019 at 10:40 am #52813

    Hi montevideomarketing,

    Please make sure you have been set the API for youtube in Customizer > JNews : Additional Option > Global API Key. Let us know if you have further questions.

    Thank you

    Post count: 125
    nasimnazanin88
    November 14, 2019 at 5:02 am #53061

    Hi,
    I used the youtube playlist before and it didn’t require API. I think this happened after a theme update.

    Post count: 6703
    Ferdy
    November 14, 2019 at 10:36 am #53065

    Hi nasimnazanin88,

    Yes, you are right. In the past, we use our API for the youtube playlist but now google has restricted the API only several requests for a day. So, from version 5.2.1 we allowing the user to insert their own API to prevent failure when getting the Youtube video data. Let us know if you have further questions.

    Thank you

    Post count: 4
    montevideomarketing
    November 14, 2019 at 10:29 pm #53090

    Could you help me with the clear steps that I need to do to obtain this API, because I am not achieving it with the default indications.
    I already put the API code and it still doesn’t show me the videos. Sure something i’m doing wrong
    Thanks!

    Post count: 6703
    Ferdy
    November 15, 2019 at 10:09 am #53103

    Hi montevideomarketing,

    In this case, please try to check your API key using this URL and replace the API_KEY with your API key:
    https://www.googleapis.com/youtube/v3/videos?id=SAID1iaq0KI&part=id,contentDetails,snippet&key=API_KEY

    After that, please provide us what you get when opening the URL above or you can share the API here, I will check the API key. you can send it here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 4
    montevideomarketing
    November 19, 2019 at 1:55 am #53202
    This reply has been marked as private.
    Post count: 12306
    Adek
    November 19, 2019 at 3:01 pm #53224

    Hi montevideomarketing,

    Based on the API response it seems you need to setup the domain restrictions. Here’s our API setup example: https://www.dropbox.com/s/un2nhytxajdozvm/WhatsApp%20Image%202019-11-19%20at%202.56.14%20PM.jpeg?dl=0

    Please try to replicate our setup on your API.

    Thank you

    Post count: 125
    nasimnazanin88
    November 20, 2019 at 1:26 am #53254

    Hi,
    I also create an API and restricted it. But the playlist still not working.

    Post count: 12306
    Adek
    November 20, 2019 at 11:48 am #53272

    Hi nasimnazanin88,

    Please try to test your API Key with this link https://www.googleapis.com/youtube/v3/videos?id=X84pK7FzkRw&part=id,contentDetails,snippet&key=YOUR_API_KEY

    You need to replace “YOUR_API_KEY” with your own API key. If your API work well it will show like this https://www.dropbox.com/s/v99y3vhalmw4pz9/Screenshot%202019-11-20%2011.46.29.png?dl=0

    Thank you

    Post count: 125
    nasimnazanin88
    November 21, 2019 at 4:45 pm #53333
    This reply has been marked as private.
    Post count: 125
    nasimnazanin88
    November 21, 2019 at 4:47 pm #53334

    I don’t know if the OAuth consent screen needs to be set. I fill the form but the status is under verification and it takes several weeks! to be verified by google.

    Post count: 3464
    Yoga
    November 22, 2019 at 10:21 am #53357
    This reply has been marked as private.
    Post count: 4
    montevideomarketing
    December 3, 2019 at 8:03 pm #53885

    I continue with this problem and I cannot solve it. I need someone to help me urgently. It is very complex to configure this to work.

    I did the test and fail.

    I need a step by step to create the api from scratch and to work properly. Thank you very much!

    Post count: 3464
    Yoga
    December 5, 2019 at 10:03 am #53985
    This reply has been marked as private.

You must be logged in to reply to this topic.