JNews – Gallery plugin

  • Post count: 8
    March 17, 2018 at 1:52 am #29661


    recently I bought a JNews template and I’m using Game Demo. I’m very satisfied with your template, it’s really fast, there is no heavy load on our server (we have 150 thousands real users per month) and there are lot of things to change. But I can’t figure out how to run classic WordPress gallery with your JNews – Gallery plugin on. When I run your plugin in deactivated mode and I launch it only in case of some galleries, it’s working, but no pictures from classic WP gallery appear.

    Can you give me an advice about using your JNews – Gallery plugin and at the same time classic gallery of WordPress in case of some galleries? I don’t like the fact that every gallery is in big window with your plugin. Sometimes I need just two pictures (previews or middle size) next to each other.

    I attached screenshots, so you can get me better.


    Thank you

    Best regards
    Michal Burian

    Post count: 2689
    March 19, 2018 at 10:23 am #29685

    Hi Michal,

    Thank you for using JNews on you amazing site 🙂
    Regarding your JNews Gallery, by default, the JNews Gallery need to be enabled when creating a gallery in a post. To be sure, please check the option from Appearance > Customize > JNews : Image & Gallery Option > Gallery Shortcode > and then sure the “Turn All Gallery to JNews Gallery” option is disabled.

    After that, in the gallery shortcode editor (in post editor) make sure the option “Enable JNews Slider Gallery” is unchecked:

    Thank you

    Post count: 8
    March 19, 2018 at 3:03 pm #29705

    Hi Rai,

    that is the problem! I have it set up. Images are not displayed 🙁

    JNews Gallery Setting - Article

    Wordpress code - article

    Article - not images :-(

    Global setting

    Post count: 11507
    March 20, 2018 at 9:52 am #29729

    Hi Michal,

    It seems there’s a minor bug on JNews Gallery plugin. Please try to go edit this file wp-content/plugins/jnews-gallery/jnews-gallery.php and jump into line 640 then replace this code $attr['data-expand'] = '-20'; with $attr['data-expand'] = '700';

    Let us know if you still getting the problem in there.

    Thank you

    Post count: 8
    March 20, 2018 at 3:54 pm #29754

    Well done! This is it.

    Thank you Adek.

    Post count: 11507
    March 21, 2018 at 10:11 am #29783

    You’re welcome Michal

    This fix will include on next theme update. Let us know if you need something else in there and don’t forget to leave 5 stars rating for JNews.

    Thank you

You must be logged in to reply to this topic.