Close

Account

Documentation

Forum

Menu

Visual Composer does not load in post

  • Post count: 3
    vincentwarnaar
    January 13, 2018 at 3:22 am #27555

    Hi there 🙂 Great theme, one problem though.. Visual Composer is only enabled in pages but not in posts. VC Role manager has been enabled to both posts and pages.
    I did a complete reinstall in cpanel, I’m using your child theme now. I saw some other people here having similar problems with VC editor not displaying on posts or pages. After some research here, I just reinstalled the whole thing and up until now I only did this:

    -Upload Jnews theme + Jnews Child theme and than activated child theme
    -Made changes to php.ini etc to make it conform to the Jnews system status standards
    -Than, I went to Jnews Dashboard to install your plugins and “only” installed and activated VC and left the other plugins to install for later.
    -I enabled VC in posts and pages in VC role manager and checked one of my posts, but again, no VC editor. VC does show up on pages.
    -Then I switched themes to a theme called “Primer”, it’s the one I chose when running the WordPress wizard installer. I checked posts again and VC shows up! Switched back to Jnews Child theme and VC doesn’t show up.. Already Tried the “WP DEBUG TRUE thing” but no errors showed up on pages or posts frontend.

    I think this is theme related. I’m really not a developper, so I hope you guys can help me out so I can get to work on it again:)
    Thank you and keep up the good work! Because the theme is just awesome!

    Cheers, Vincent

    ### THEME INFO ###

    Themes name : JNews – Child Theme
    Themes Version : 1.0.0
    Themes License : ✔

    ### WordPress Enviroment ###

    Home URL : https://webbble.com
    Site URL : https://webbble.com
    Login URL : https://webbble.com/wp-login.php
    WP Version : 4.9.1
    WP Multisite : –
    WP Debug Mode : Disabled
    PHP Memory Limit : 256 MB
    WP Memory Limit : 256 MB
    WP Language : en
    WP Upload Directory : ✔
    Number of Category : 1
    Number of Tag : 0

    ### Server Enviroment ###

    Server Info : Apache
    PHP Version : 7.0.23
    PHP Post Max Size : 64 MB
    PHP Time Limit : 3000
    PHP Max Input Vars : 3000
    SUHOSIN Installed : –
    WP Remote Get : ✔
    PHP Image library installed : ✔
    CURL Installed : ✔

    ### Active Plugins ###

    WPBakery Page Builder : by Michael M – WPBakery.com – 5.4.5

    ### End ###

    Post count: 7182
    Adek
    January 15, 2018 at 4:10 pm #27609

    Hi Vincent,

    Thanks for your compliment.

    Regarding this thing, please try to visit this topic here http://support.jegtheme.com/forums/topic/visualcomposer-not-loading-correctly/#post-26366

    Let me know if you need something else in there.

    Thank you

    Post count: 3
    vincentwarnaar
    January 15, 2018 at 4:47 pm #27614

    You guys rock! Thank you it worked!

    Post count: 7182
    Adek
    January 16, 2018 at 10:18 am #27653

    Glad to hear that vincentwarnaar 😀 Don’t forget to leave 5 stars for JNews. Let us know if you need something else.

    Regards

    Post count: 3
    vincentwarnaar
    January 18, 2018 at 5:14 pm #27790

    Hi just another question, is there any option to customize the social share buttons. I see they’re different in each demo, like rounded, cornered or custom colors etc. I can only find customization for social account buttons but not for the social share buttons. Is this possible? Thanks!

    Post count: 7182
    Adek
    January 19, 2018 at 10:20 am #27832

    Hi vincentwarnaar,

    Yes, it’s possible. We’ve been provided several options to customize it. You can find it on the Customize > JNews : Single Post Option > Single Post Element then find share options. But if you have want to have certain style you may need to add some custom CSS code in there.

    Thank you

    Post count: 3
    vincentwarnaar
    January 20, 2018 at 5:04 pm #27869

    Thanks! this will work.

    I encountered another problem. This time with Autoload function. I inserted your custom code in child theme to enable VC for posts. This works, but not with the AUTOLOAD function enabled.

    When enabled, the first post is loaded correctly with VC style, but when scrolling down and it autoloads the next post, it only shows the VC editor code something like this:

    [/vc_column_text][/vc_column_inner][/vc_row_inner][/vc_column][vc_column][vc_empty_space height=”20″][/vc_column][/vc_row][vc_row][vc_column css=”.vc_custom_1516392356119{background-color: #ffffff !important;}”][vc_empty_space height=”20″][vc_tta_tabs style=”I etc etc.

    I’ve now disabled autoload and enabled “next post popup” down on the post. When I click that it will load the next post correctly with VC style.

    I also tried other editor plugins and enabled them only for posts like beaver builder etc, but they don’t load correctly either. So I guess the autoload function only reads VC once when the whole page loads, but it needs to read VC again and again for every new post that is autoloaded.

    So my question is there any way to bypass this with another line of code? Because I love the autoload function, but I also love VC in posts 😛

    Thanks for all the great support so far!

    Cheers Vincent

    Post count: 7182
    Adek
    January 22, 2018 at 11:40 am #27922

    Hi vincentwarnaar,

    Basically, we’re using VC editor for creating the page and not for the post yet. But you can still create a post with VC editor but it might generate some problem for certain condition like your problem above. We will take a look at this thing for a further theme update.

    Thank you

You must be logged in to reply to this topic.