Twitter widget

  • Post count: 8
    July 15, 2014 at 1:23 pm #1715

    Hi, i have problem to make the twitter widget work.
    In the Twitter Username field, do we have to insert the full URL or only the username?
    I try the both case but can’t see any tweets, only the follow button with my username.

    In twitter app, does the access level “Read only” is enough?
    Do i have to insert “callback url” or leave this field blank?
    Have you got documentation for your widget?

    Thank you for your help,
    Best regards

    Post count: 8
    July 16, 2014 at 1:24 am #1729

    Works now, i had to wait a little to take effect i think…

    Post count: 8
    July 16, 2014 at 9:55 am #1764

    It Works but sometimes i have this message above the tweets :

    file_put_contents(/home/www/…/wp-content/plugins/jkreativ-plugin//lib/twitter/cache/twitter.txt) [function.file-put-contents]: failed to open stream: Permission denied in /home/www/…/wp-content/themes/lanches-themes/admin/widget-template/twitter-widget.php on line 156

    Do i have to change permissions of a folder or a file, for example the /cache/ folder in your jkreativ-plugin folder is set to 755…

    Also in this folder i can’t see twitter.txt file ? And i know the host provider set 664 to files per default ?
    So do i have to create a twitter.txt file and set permissions to 755 or 777 ?

    PS : Also is it normal to have 2 slashs on the first url of error message here : “jkreativ-plugin//lib”

    Best regards

    Post count: 8
    July 24, 2014 at 3:06 pm #2098

    Hi, i always have problem with the twitter widget in the footer :

    here is the warning message :

    Warning: file_put_contents(.../wp-content/plugins/jkreativ-plugin//lib/twitter/cache/twitter.txt) [function.file-put-contents]: failed to open stream: Permission denied in .../wp-content/themes/jkreativ-themes/admin/widget-template/twitter-widget.php on line 156

    The tweets works but on first load i always have this message ??
    What can i do to resolve this issue ?

    PS : when i refresh my homepage, the message disappear…

    Post count: 2355
    July 26, 2014 at 3:11 am #2153

    Hi swisskud,

    It seems your file permission denied to write file at this location wp-content/plugins/jkreativ-plugin//lib/twitter/cache/twitter.txt. Please change those file permission to 777 so the plugin can get permission to write those file.

    Thank you

    Post count: 8
    September 19, 2014 at 11:45 am #4252

    Hi, thank you changing file permission to 777 at his location wp-content/plugins/jkreativ-plugin//lib/twitter/cache/twitter.txt do the job, thanks a lot for your help.

    Now i have another problem. I need to change the twitter app. ( the first one created was for demo with my account ) So i create another twitter app for my client and insert new access with API key, API secret, Access token and Access token secret.

    The problem is i always see my tweets and not the new client tweets.

    I try to delete ‘twitter.txt’ file, but always wrong tweets.
    I try to re-upload all the source files for plugin ‘jkreativ-plugin’ and set permission 777 to the file and /cache/ folder, but still the same issue…

    Also the twitter.txt file seems not to regenerate. It’s really strange because i always can see my tweets ( even i delete the demo app )

    Is there another cache file hidden for the tweets plugin ?

    Post count: 2516
    September 23, 2014 at 9:28 am #4412

    hi swiss, it will cache about 3 hours on your database. if you recently change it, wait until 3 hours to make kind of change.
    also if in any case twitter api find any problem, it will load your latest twitter that saved on file (cache file)
    you will need to make sure every input is correct. if you still not sure about twitter api, you can use our twitter api that you can get from import content.

    Thank you

    Post count: 8
    September 23, 2014 at 11:46 am #4418

    Ok thank you for the message, the change is done after 3 hours like you said.
    And thanks for your advice !

    Best regards

You must be logged in to reply to this topic.