Close

Account

Documentation

Forum

Menu

translate problems with upgrade

  • Post count: 15
    Travelcards
    April 4, 2016 at 9:15 am #19435

    Hi,
    we have re-installed the parent theme as suggested as it was updated by your company.

    Once working, this new version of theme cancelled all our translations: Subscribe button, Continue reading button, Share this Article, Trending posts, Next, Previous… and so on.
    We translate with Loco Plugin.

    At this stage we re-translated everything, on Parent and Child themes.
    It is not working, as it used to before the update.
    Please help us.

    Post count: 1844
    Rai
    April 5, 2016 at 1:42 am #19444

    Hi,

    There is few updates (v1.1.0) in language file but it should not be a problem, please try to “Sync” the Template(POT) file and your translations as well to update get updated files.

    Thank you

    Post count: 15
    Travelcards
    April 8, 2016 at 5:36 pm #19496

    Hello Rai,

    It doesn’t work.

    I’ve checked with Loco developer (the conversation is here: https://wordpress.org/support/topic/compatibility-with-falive-theme-issues-1?replies=7#post-8251724)and readed the Loco’s bginners guide: https://localise.biz/help/wordpress/translate-plugin/beginners#setup

    1) I’ve uninstalled the plug in and deleted all the .po and .mo files in wp-content\languages and wp-content\languages\themes

    2) I added to /wp-content/themes/falive-themes/style.css the following row:

    Domain Path: /lang/

    this because inside the Falive theme folder, where the POT file is, the sub folder language are named instead lang
    (see Loco beginners guide point 3: “Before you do any translating, make sure the following folder exists on your site, and is writeable by the web server: wp-content/languages/themes . If you have automatic updates enabled this is most likely set up for you. But check it anyway” check also my conversation with Loco developer: https://wordpress.org/support/topic/compatibility-with-falive-theme-issues-1?replies=7#post-8251724).

    3. I re-installed the Loco plugin and followed all the path in the beginners guide until n°10 (I chose the global language directory, I translated, I check if the PO and MOI file exists and, yes they do. And off course I press Sync after saving the files. I press Sync also in the Template POT section in Loco.

    The translation doesn’t work. Wha shouuld I do? Could you please detail cleary, step by step please?
    Thank you very much

    Post count: 15
    Travelcards
    April 8, 2016 at 5:41 pm #19497

    a picture of my Dashboard \ My falive version: https://www.dropbox.com/s/rqc7subdxg3p3tp/Senza%20titolo-1.jpg?dl=0

    Post count: 1844
    Rai
    April 9, 2016 at 2:13 am #19499

    Hi Travelcards,

    If you already reinstalled the plugin it should refresh the language file, so you dont need to add those code:

    because theme itself already declare where to load language files.

    Please also try clear your browser cache.

    Thank you

    Post count: 15
    Travelcards
    April 10, 2016 at 11:57 am #19507

    Hi Rai

    I canceled the rows

    but everythings is still the same: it doesn’t work. I check in the Loc plugin: my transaltions are saved.

    What can I do?

    Thanks for your help

    Post count: 15
    Travelcards
    April 10, 2016 at 11:59 am #19508

    (wops, sorry for the bad spelling before. I forget to say I’ve also clear my browser cache, off course)

    Post count: 1844
    Rai
    April 11, 2016 at 1:43 am #19517

    It’s weird, we never face this issue before and on our side the translation also working fine so far. Can you provide backend access for further investigating purpose?

    Thank you

    Post count: 15
    Travelcards
    April 11, 2016 at 3:12 pm #19539
    This reply has been marked as private.
    Post count: 1844
    Rai
    April 12, 2016 at 3:17 am #19548

    Hi,

    I checked your site and noticed your language file is located at global directory instead of theme directory, I try to create new language (Bahasa) with theme directory option and it works. Please try to recreate your lang file and make sure you select option: “creare in themes/falive-themes/lang”:

    Thank you

    Post count: 15
    Travelcards
    April 12, 2016 at 3:23 pm #19567

    I saw your translation, but when I swicht to see the front end, all is still the same. What I have to do to actually change the text in english (like read more, trending post, subscribe and so on…)?

    Post count: 15
    Travelcards
    April 12, 2016 at 3:42 pm #19568

    I try adding to the file root/config.php the missing line:

    define (‘WPLANG’, ‘it_IT’);

    but nothing happen…

    Post count: 15
    Travelcards
    April 12, 2016 at 4:30 pm #19569

    Allright:

    In file the file /config.php I’ve deleted the line I did before (because deprecated):
    define(‘WPLANG’, ‘it_IT’);

    And I have added to config.php:
    define(‘LANGDIR’, ‘/public_html/wp-content/themes/falive-themes/lang’);

    Then I added a new translation with Loco as you said on themes/falive-themes/lang

    And now it works!

    I just hope the line: define(‘LANGDIR’, ‘/public_html/wp-content/themes/falive-themes/lang’); is not deprecated,

    Thank you very much Rai, you helped me a lot!

    Post count: 1844
    Rai
    April 13, 2016 at 1:33 am #19575

    Hi Travelcards,

    Actually, you don’t have to add any additional code but just move (or create new) the translation file into theme’s directory, as I mentioned above. You can also see my test language file (Bahasa) its located in theme’s directory “/public_html/wp-content/themes/falive-themes/lang” instead of “/public_html/wp-content/languages/”.

    Thank you

    Post count: 15
    Travelcards
    April 13, 2016 at 3:11 pm #19584

    Ok, it all allright except for two things:

    – it doens’t translate dates in posts and the “Submit” button in the widget “subscrbie form” in the sidebar.

    – when I stated translating, there still was an Italian PO file in Loco dashboard. I started a new transaltion and set themes/falive-themes/lang. I did the transaltion, I saved, that works, but I dind’t see another file.
    And the italian one contain old translation I did before… well, anyway it works.

    Thanks again Rai!

You must be logged in to reply to this topic.