Close

Account

Documentation

Forum

Menu

Portfolio tab not working properly

  • Post count: 5
    Xiba
    January 4, 2016 at 11:05 am #17325

    Experiencing two issues with back end of the portfolio tab.

    Issue 1:

    I’m currently not able to create portfolio from the porfolio tab.

    Every time I try to add/ edit a new portfolio I don’t get the option to save and publish instead the “submit for review” button is available. And once it is clicked on, the following error message appears: “You are not allowed to edit this post”, not allowing me to create or save any portfolios.

    Issue 2:

    Why is the “metro” Portfolio layout option not shown/available in the portfolio tab? as shown in the demo site, which was the main reason for purchasing this template.

    Post count: 2749
    Jegbagus
    January 5, 2016 at 1:39 am #17333

    hi Xiba,

    1. i think its problem with your user account. are you sure that you login with administrator role? it seems you are not having capability to edit the content.

    the other problem may because plugin that you currently use. try to disable all plugin except the one that include with this themes.

    or you can follow this thread how to solve this issues : https://wordpress.org/support/topic/no-publish-but-submit-for-review-button-displayed-to-site-admin

    2. if you previously do demo import, you can see that on portfolio page (parent page) you will see that we are using normal layout. and on each of single portfolio child, you will need to define thumb width & thumb height. for example if you are want your thumb bigger than any other thumb, you can give 2 thumb width & 2 thumb height.

    Thank you

    Post count: 5
    Xiba
    January 6, 2016 at 2:47 am #17363
    This reply has been marked as private.
    Post count: 5
    Xiba
    January 6, 2016 at 3:59 am #17366

    Also in WP admin every time I visit the portfolio tab and click on new tab the following error also appears on the top of my screen

    Warning: Creating default object from empty value in /home3/xxxx/public_html/xxxxx.com/wp-admin/includes/post.php on line 632

    Which i believe must be the reason for only having the “save and publish” instead the “submit for review” button..

    Post count: 5
    Xiba
    January 6, 2016 at 4:01 am #17369

    Which i believe must be the reason for receiving the “submit for review” instead of the “save and publish” button..

    Post count: 2749
    Jegbagus
    January 6, 2016 at 4:10 am #17371

    hi Xiba, unfortunately its how our support work. you may take a look also about our support policy right here : http://support.jegtheme.com/support-policy/

    also have you already trying to disable all plugin that not related to the themes first?
    if problem still exist, please disable all plugin & themes as well and use default wordpress themes.
    are those problem only appear on portfolio or post / page also have the same issues?

    we are believe that this issues is not themes related issues, and most of the time other author will not giving any support for issues that not related to their themes. but we keep helping you to resolve issues you having.

    Thank you

    Post count: 5
    Xiba
    January 6, 2016 at 4:32 am #17372

    Both issues are related to the theme, I have followed the instructions to download and use your theme, I am experiencing the same issue as one of your other users here, which you have offered support and to look in to their wp admin>

    http://support.jegtheme.com/forums/topic/you-are-not-allowed-to-edit-this-post/

    yes, I have disabled all plugins that are not related to the theme and I have disabled all plugin & themes as well restarted and used default wordpress themes and the problem is still there.

    the problem only appears on portfolio not on any other posts / pages?

    Post count: 5
    Xiba
    January 6, 2016 at 6:27 am #17392

    Hello Jegbagus

    I don’t believe the theme is compatible with WordPress 4.4, I switched back to WordPress 4.3 and the problem is solved.

    My second issue is that; how do i access and use “Metro” style layout for the portfolio as shown in the demo? the only options available are Normal, Masonary and Pinterest.

    Post count: 2749
    Jegbagus
    January 7, 2016 at 3:09 am #17408

    hi xiba, i really don’t know what is actually happen. if you able to give me access to your admin panel to check what is actually happen it will be very great.

    on my test site, i also use wordpress 4.4 and we don’t have any problem with it. you can take a look right here (you will notice we are using wordpress 4.4.1 on the bottom right of image)

    but yes, it may because server, or upgrade issues on WordPress, database foreign key issues, or other factor that causing this issues that i not really sure what is it. the issues is so random, its very hard for me to make sure what is the problem where i unable to replicate the problem. but i can assure you that its not themes issues. if its a themes issues, this support forum will be flooded with complain where we have thousand user that use this themes already (we have been in this situation before, photology and jkreativ using almost the same code so i believe it identical issues)

    and for your second question, metro layout is actually a normal layout with different size of single portfolio.
    if you are on single portfolio you will see this option, you can take a look at bottom page that you have option to change height and width of your portfolio

    we don’t provide limitation what kind of layout you want to create, so you can create it or modify size of each block of portfolio as you need it.

    Thank you

    Post count: 2749
    Jegbagus
    January 7, 2016 at 3:16 am #17410

    or maybe you can upgrade to wordpress version 4.4.1. i try to search line 632 on post.php, but i unable to find any code right there (its only a comment)
    it may fix the issues you having.

    also can you inform me php version of your server?

    Thank you

You must be logged in to reply to this topic.