Close

Account

Documentation

Forum

Menu

Portfolio 404 Errors

  • Post count: 32
    MarcheLive
    April 17, 2015 at 7:29 am #10911

    Here’s what I’m seeing. When I have my Permalinks set to ‘Default’, I have no problem editing or viewing my Portfolios.
    If I set the Permalinks to any other setting, I can edit but I cannot view my Portfolios. I only get 404 errors.

    I flushed my Permalinks and recreated my .htaccess file. Still only works in ‘Default’.

    The Portfolio Parent for each portfolio is blank. When I try to select a Portfolio Parent there are no selections.
    Do I need to create a Parent? If so, how??

    Post count: 32
    MarcheLive
    April 18, 2015 at 6:49 am #10937

    I’m still chasing down this 404 error. As a test I did a new install of WP and reinstalled the theme without dummy data. I set the Permalinks to post-name then created a portfolio. After saving I attempt to view the portfolio and get a 404 not found error. If I set the Permalinks to ‘Default’, the portfolio can be viewed.

    What’s up with this?! I cannot use this theme with Default Permalinks. That totally throws SEO out the window. You guys need to get this fixed!

    Post count: 32
    MarcheLive
    April 18, 2015 at 7:29 am #10957

    Dek, I see you responded to many of the open questions. How about helping me out here?

    I’m looking thru all 404 portfolio error questions and it appears Portfolio simply does not work with Permalinks. I wish I had known before buying!

    If you have a workaround that will allow me to link to my portfolios while using Permalinks (post-name), please let me know or at least respond in some way. You can email me directly: [email protected]

    Post count: 6700
    Adek
    April 18, 2015 at 7:30 am #10958

    Hi MarcheLive,

    Please try to re-save your portfolio (just click Update Button) to regenerate the link of your portfolio.

    Thank you

    Post count: 32
    MarcheLive
    April 18, 2015 at 7:34 am #10960

    That does not work. I’ve done it multiple times.
    I also tried reactivating the Jkreativ plugin. Still nothing.

    Also, when I look at the drop down options for Portfolio Parent it’s blank. Should there be something there?? I reinstalled the theme on a fresh WP install to see if that was the problem. Still have the same error. Ping me on email and I will give you access to my site so you can check it out for yourself.

    Post count: 32
    MarcheLive
    April 20, 2015 at 5:44 am #10991

    Dek,
    Thank for you helping me get this corrected. I really appreciate the great support!

    To anyone that has the same problem, here is the simple solution.
    You first need to create a Page using Template: ‘Portfolio – Portfolio List Page’
    Once you create this portfolio list page, the name will appear in the Portfolio Parent dropdown in the portfolio you create.

    Each portfolio must have the Portfolio Parent identified or you will get a 404 error when using Permalinks.

    Post count: 6700
    Adek
    April 20, 2015 at 7:45 am #10999

    You’re welcome MarcheLive and thanks for your kind words on above 🙂

You must be logged in to reply to this topic.