Close

Account

Documentation

Forum

Menu

One page navigation

  • Post count: 21
    huno
    February 2, 2015 at 9:42 am #8764

    Hello,

    I searched everywhere in the doc and forum but i can’t manage to find my answer, sorry.

    Im making a home page as Landing Page builder + an other page which is a blog.
    The home page has different Section ID that I gave names.

    I would like to put those Section ID in my main menu, but I can’t manage to find the right way to do it.

    When I make a link to #sectionid it work my url will look like this : http://localhost/site/#sectionid1
    but if i’m in the BLOG, I can’t click on the menu link anymore or it will just add the #sectionid to my url: http://localhost/site/blog/#sectionid1
    (it should go back to http://localhost/site/#services)

    Then I tried to make links with http://localhost/site/#sectionid1 -2 -3 etc…
    but then all the menu link are HOVER (with the bottom line showing we are viewing the page)

    How shall I proceed ??

    THank you!

    Post count: 6436
    Adek
    February 3, 2015 at 9:28 am #8790

    Hi huno,

    Please try to visit this topic http://support.jegtheme.com/forums/topic/one-page-website/
    Hopefully it can help you

    Thank you

    Post count: 21
    huno
    February 4, 2015 at 1:24 am #8822

    Hello,

    As I explained i tried this solution and it doesnt work.
    please have a look on my website http://www.siaac.cn

    The hover link of Home and Contact are both ON

    aa

    Is there a little hack to do on the css to fix this problem ?

    Post count: 21
    huno
    February 5, 2015 at 9:04 am #8855

    Waiting a good solution i installed a plugin where i can activate and deactivacte menu items depending on which page I am. So i made a menu for the blog and a menu for the home page. Im not fully happy with this side solution but until you find better…

    Post count: 6436
    Adek
    February 7, 2015 at 8:50 am #8907

    Hi Huno,

    It’s happen because on home and contact have same page url so the hover link will activate on both. You will need to add some custom css to remove those hover effect.

    Thank you

You must be logged in to reply to this topic.