Close

Account

Documentation

Forum

Menu

Homepage don't update when I post a new post

  • Post count: 20
    saojoaquimonline
    March 31, 2018 at 2:27 am #30088

    My site is hosted on own wordpress.com in a premium account. However, after installing jnews and Visual Composer, the homepage is not automatically updated even if you select the categories in Visual Composer. It seems that there is some cache problem …. But in wordpress.com there is no way to install cache plugins. Each time I submit a new post it is not shown and does not update on the homepage.

    At first, I thought that this was a problem in Visual Composer, but then I tested it with other themas and saw that it is working correctly. Only Jnews is that it is not updating posts on the homepage. How can I solve this problem?

    Look the problem: https://prntscr.com/iy1wxr

    Post count: 28
    pswebpros
    March 31, 2018 at 9:46 pm #30094

    I’m having a similar issue and am using wordpress.org site, so it’s not just you. I hope they respond soon. When I switch to default theme, posts show up just fine.

    Post count: 20
    saojoaquimonline
    March 31, 2018 at 10:29 pm #30095

    I received your email response:

    “hi saojoaquimonline, if you filter the content with category, it will only show content of those category on those block. so if you recently add new post with different category, it obviously will not show on your homepage block.

    what is way is you can flag everythink you want to show on front page block with tag. for example you give “homepage” tag. so if you want to show it on home ppage, you will just need to add tag on “homepage” on your article.”

    But the point is that “I’m not selecting a different category” than the one on the block of homepage.
    As for the tip of can flag everythink with: “homepage” tag, also did not work!
    I recorded a video of the screen so that I can better understand the problem: Please look this:
    https://goo.gl/huqpeZ

    Post count: 9465
    Adek
    April 2, 2018 at 9:30 am #30109

    Hi There,

    One of our customers also faced the similar issue here http://support.jegtheme.com/forums/topic/top-page-not-updated-cache-problem/ and it may be caused by batcached from WordPress.

    Please provide me login to your website so i can check it directly on my side. You can send it here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 20
    saojoaquimonline
    April 2, 2018 at 12:22 pm #30123
    This reply has been marked as private.
    Post count: 9465
    Adek
    April 3, 2018 at 9:40 am #30140

    Hi saojoaquimonline,

    1. For post not updating please try to replace the content of this file wp-content/jnews/class/Module/ModuleQuery.php with this one here https://pastebin.com/RQnR8x8b. When you’re login, it will just work fine. But when you’re not login, you need to wait for 1 – 5 minutes to see the result because there’s a cache on your website (https://www.dropbox.com/s/l9rup46fk0eiwvv/Screenshot%202018-04-03%2009.33.39.png?dl=0).

    2. For the video embed issue, please try to put this code remove_filter( 'embed_oembed_html', 'jetpack_responsive_videos_maybe_wrap_oembed', 10 ); into functions.php file.

    Thank you

    Post count: 20
    saojoaquimonline
    April 23, 2018 at 9:41 am #30932

    After updating to version 2.0 of the theme, the caching problem has returned, so that new posts do not appear on the homepage after posting a new post as reported in this call:

    Post Link: http://support.jegtheme.com/forums/topic/homepage-dont-update-when-i-post-a-new-post/#post-30140

    I did not want to change the wp-content / jnews / class / Module / ModuleQuery.php file for fear that the changes contained in version 2.0 might cause some kind of conflict on the site. Can you tell me if it is just to change the files by the one that sent me: https://pastebin.com/RQnR8x8b – Or if you have other modifications in this file that need a new code?

    Post count: 9465
    Adek
    April 24, 2018 at 11:03 pm #31047

    Hi saojoaquimonline,

    In this case, you may need to use the child theme to avoid this issue when doing theme update. Please check our documentation regarding using child theme here http://support.jegtheme.com/documentation/child-theme-3/. Then you just need to create this folder on the JNews child theme wp-content/themes/jnews-child/class/Module/ModuleQuery.php

    Thank you

You must be logged in to reply to this topic.