Close

Account

Documentation

Forum

Menu

Reply To: empty page in 2 of my 3 languages

Post count: 69
cdaldoss
May 6, 2015 at 10:40 am #11429

Hi Dek,

I’m contacting you again about this matter us I had WPML support checking at it and they just find out now that is a compatible problem. I paste you down here the last answer I got where they say which is the problem and they suggest you how to fix it but you could find thefull support ticket conversation at this link: Full WPML support ticket

ANSWER FROM WPML SUPPORT

I suggest contacting with the theme author and ask them apply to our Go Global program: http://wpml.org/documentation/theme-compatibility/go-global-program/ .

The theme author can announce anything but we can make sure and test with the themes that are listed under our lists only.

Actually I can not find the reason and the way to give you a temporary workaround.

This is really a compatible problem when it looks like in the register_post_type function, the theme author is using the parameter ‘rewrite’ without the value ‘portfolio’ – the same with post_type.

(The file jkreativ-themes\admin\post_type.php), line 70

1
‘rewrite’ => array(‘slug’ => ‘%portfolio_page%’,’with_front’=>true),
This option should be ‘rewrite’ => true

We wrote about this specific case at https://wpml.org/documentation/getting-started-guide/translating-page-slugs/ (in the bottom) and https://wpml.org/faq/how-to-translate-custom-types/

Actually it’s not simple like editing a line because the theme author is using a lot of filters for this.

—–

I hope you could fix this matter soon as after I resolve it redoing all the portfolios I had it again and now it’s fixed with a redirection plugin to now have broken URL in the website.
thanks nad regards
Carlotta