Close

Account

Documentation

Forum

Menu

URGENT! Jkreativ Broken after WP Upgrade [Jan2016]

  • Post count: 7
    spoiler
    January 13, 2016 at 4:59 pm #17657

    Jkreativ is completely worthless now after updating theme and/or WordPress. There are shortcodes that are part of the Jkreativ plugin that get stripped after making changes while using the “classic” editor or “visual” editor. I have contacted “Visual Composer” developers and they say there are shortcodes that are not native to their product and that the code would not be stripped out after saving the page, these are related to the Jkreativ plugin. This issue was not there before updating to the newer versions of the Jkreativ theme so there could be an issue with the theme, the related plugin, or how it interacts with the new versions of WordPress.

    Problem Described:
    When I am in the “classic editor” on one of the demo pages [Home Villa/Hotel for example], I simply open a widget and save it, then update the page and BOOM!!! The page does not have the correct motion or positioning it had before, and the code is significantly shorter than before with several Jkreativ shortcode items removed entirely. When working in “backend” mode, with the HTML editor, the code remains intact after page update so the stripping is related to being in the different edit modes. The same issue happens when, in “backend”” editor mode, when I switch to the visual editor and update the page… the code gets stripped.
    All of the code that get stripped comes directly from the Jkreativ widgets and even if I create a new page and add the widgets, it still strips the code.

    What I have done:
    I have tried older versions of the theme, still no effect
    I have completely re-installed WordPress and the theme, still no effect
    I have disabled and re-enabled the plugin and the theme and seen some effect momentarily but as soon as I update, the code disappears.
    I have tried disabling the visual editor, still nothing

    Jkreativ codes that get stripped:
    Some parallax shortcodes, section_id, section_name or any section related attributes in the row element. Also jeg_image_sequence _wrapper and jeg_image_sequence_item is not VC standard shortcodes.

    PLEASE HELP! THIS USED TO BE ONE OF MY FAVORITE THEMES BUT NOW IT IS COMPLETELY USELESS UNLESS YOU LIKE USING THE BACKEND CODE TO EDIT.

    Thanks!

    Post count: 7148
    Adek
    January 15, 2016 at 1:36 am #17711

    Hi spoiler,

    Thanks for your detail info about the problem encountered in there.

    If so, can you help me to provide login credentials into your wp admin panel so i can check it directly what actually happen in there. You can send it here and check the Set as private reply option below.

    Thank you

    Post count: 7
    spoiler
    January 15, 2016 at 10:26 am #17727
    This reply has been marked as private.
    Post count: 7148
    Adek
    January 16, 2016 at 1:47 am #17738

    Hi spoiler,

    I’ve been check your site in there, but i can’t do several test on your site because i don’t have capability as administrator. Can you provide user as admin so i can easily to check your site.

    Anyway, you’re using Visual Composer plugin that not compatible with our themes. Please try to use VC plugin that come with our theme. We’ve been include the VC plugin file on theme package.

    Thank you

    Post count: 7
    spoiler
    January 17, 2016 at 8:12 am #17763
    This reply has been marked as private.
    Post count: 7148
    Adek
    January 18, 2016 at 2:27 am #17775

    Hi spoiler,

    Actually, we just released new version of Jkreativ a few days ago that include VC plugin v4.9.2.

    Please try to update your themes and several required plugins as well and keep only required plugin activate for a while. You can take a look on the readme.txt file about change log.

    Let us know if you have further question.

    Thank you

    Post count: 7
    spoiler
    January 18, 2016 at 5:37 am #17780

    It is still not working. I removed and deleted everything JKreativ and then uploaded the new themes via FTP and then re-installed WordPress just to be sure, then activated the theme, added and activated plugins, then opened the Villa page, saved a widget, updated the page and lost all of the motion slide-in fonctionality on the refreshed page.

    This is frustrating, I have a client waiting on me and I really need to know why your theme is not working. What are the PHP requirements? Maybe I have a hosting issue – Are you getting any other complaints?

    Can you tell me why saving the page makes code disappear?

    Please help.

    Post count: 7148
    Adek
    January 18, 2016 at 9:02 am #17781

    Hi spoiler,

    I’ve been check your site previously and i think it will works fine now.

    Also you will need to update this file regarding this issue jkreativ-themes/admin/vc/element.php and you can replace the content of those file with this one below. You can make a backup file for some reason.