Close

Account

Documentation

Forum

Menu

Stop Slider Side

  • Post count: 12
    dleon1
    July 24, 2015 at 7:19 pm #13152

    Hi again,

    I recently changed the setup of my site and now it would be preferable if the slider and the widgets inside could stop moving along with the window as you scroll and just stay put. Is that something that can be done?

    Thanks much!

    Post count: 1844
    Rai
    July 27, 2015 at 4:18 am #13172

    Hi @dleon1,

    For the slider you can disable Autoplay Slideshow from homepage. For widgets, do you want the widgets not follow when scrolling down (sticky)?

    Thank you

    Post count: 12
    dleon1
    July 29, 2015 at 4:53 am #13217

    Hi Rai,

    I actually meant the sidebar, not the slider, not sure how I mixed those two up. Yes, I would like the widgets in the sidebar to stop moving down the page with the window when you scroll.

    Thanks again

    Post count: 2247
    Jegbagus
    July 30, 2015 at 3:40 am #13221

    hi dleon1, to make something like that you will need to change the file directly.
    you can use this file : http://pastebin.com/G4SWhW9W
    and put it on falive themes folder > js > main.js (overwrite this file)

    Thank you

    Post count: 1844
    Rai
    July 30, 2015 at 3:50 am #13224

    Hi dleon1,

    *Alternative method (same result):

    You need to edit template file for those kind of customization. If you able to do it, please update file that located at: falive-themes/js/main.js:

    Go to line: 402, you should find this code:

    Then replace with this code:

    Save the file and then clear your browser cache to load the updated file.

    Please let me know if you encountered problem.

    Thank you

    • This reply was modified 2 years, 2 months ago by  Rai.
    Post count: 12
    dleon1
    July 30, 2015 at 6:05 am #13233

    Thank you so very much once again, that did the trick.

    Post count: 12
    dleon1
    July 30, 2015 at 6:43 am #13236

    Actually, after some further testing, it looks like that doesn’t work. I’m certain I implemented the code correctly, it looks the same way in my theme now as it does in your example. I even tried deleting that line altogether but the sidebar is still sticky.

    Post count: 2247
    Jegbagus
    July 31, 2015 at 2:39 am #13246

    hi dleon1, can you give me URL where you have the problem? i will take a look.

    Thank you

    Post count: 12
    dleon1
    July 31, 2015 at 6:31 am #13252
    This reply has been marked as private.
    Post count: 1844
    Rai
    August 1, 2015 at 3:40 am #13266

    Hi @dleon1,

    I checked your site it seems the main.js still enable the do_sidebar_follow(). Have you edit as I mentioned above? If you use any caching plugin / dns caching such as cloudflare, I suggest you to clear the cache after you edit the file.

    Thank you

    Post count: 12
    dleon1
    August 1, 2015 at 5:54 am #13270

    That was it. I cleared my CloudFlare cache and it now works like a charm. I can’t thank you enough for your amazing support!

    Post count: 1844
    Rai
    August 3, 2015 at 3:55 am #13307

    Hi @dleon1,

    Glad to hear that work for you. Please let us know if you have further support questions (in other topic).

    Kind regards,
    Rai

You must be logged in to reply to this topic.