Close

Account

Documentation

Forum

Menu

Soundcloud Not Working in Portfolio

  • Post count: 2
    wdrhys
    May 11, 2015 at 10:39 am #11574

    Hi folks.

    We’ve building a site using JKreativ, and have run into a problem with embedding a Soundcloud track in the Portfolio.
    Soundcloud works in the individual blog posts, but the portfolio versions do not work. The iframe loads and the Soundcloud logo appears, however no audio plays, no controls or any info appears. This is the same for both lightbox options that support Soundcloud.

    If entered in another way (like the blog post version: https://soundcloud.com/users/song) rather than the iframe link, an error shows saying it’s the wrong type of link, or is invalid.

    Curiously, the Soundcloud iframe appears correctly in the Edit Page area.

    Please advise on how to remedy the issue. Thanks!

    http://www.operasonic.co.uk/wp/media/recordings/

    Post count: 6666
    Adek
    May 12, 2015 at 9:03 am #11594

    Hi wdrhys,

    It seems embedding a Soundcloud track in the Portfolio will not works if you’re using Side Content Portfolio layout. You will need to use another portfolio template to make it works fine.

    Let me know if you have further question.

    Thank you

    Post count: 2
    wdrhys
    May 12, 2015 at 10:54 am #11610

    Hi again.

    Is there a reason for this?

    I’ve switched it to AJAX, which now lightboxes on the Portfolio page. However, it gets stuck loading unless you click to the next one and back.

    Additionally, will this be required for video content, or just Soundcloud?

    Thanks in advance.

    Post count: 6666
    Adek
    May 13, 2015 at 8:46 am #11631

    Hi wdrhys,

    I’ve been check the link that you attach previously. But it seems they are not working at the moment. Can you send me again the url of those page. I just want to make more sure in this case.

    Thank you

    Post count: 2
    wdrhys
    May 13, 2015 at 10:44 am #11636

    Hi again Dek.

    We’ve moved it to the root now as the site has undergone a soft launch.
    http://www.operasonic.co.uk/media/recordings/

    Thanks again.

    Post count: 6666
    Adek
    May 14, 2015 at 8:38 am #11662

    Hi wdrhys,

    It seems you will need to put an image on the first place to make Soundcloud appears when you’re using Ajax Portfolio. Anyway you can try to using Cover portfolio, it should works fine i think.

    Thank you

You must be logged in to reply to this topic.