Close

Account

Documentation

Forum

Menu

MySQL Warning

  • Post count: 13
    Gouvea
    October 24, 2014 at 12:50 pm #5624

    Hi,

    I’m having a problem on the portfolio section. Here’s the warning:

    How can I fix it?

    thanks

    Post count: 13
    Gouvea
    October 24, 2014 at 3:54 pm #5629

    I asked my host about this issue and I was told that they moved the website to a new server running PHP 5.5. Previous server was running PHP 5.4.

    Is this related?

    Post count: 13
    Gouvea
    October 24, 2014 at 6:33 pm #5633

    Confirmed. I asked the host to move website back to previous server (PHP 5.4) and everything is ok. The host will actually move all websites to the new server within 10 days, so support to change this deprecated: mysql_real_escape_string(): is stil appreciated.

    thanks,

    Post count: 2483
    Jegbagus
    October 25, 2014 at 1:18 pm #5661

    hi Gouvea, glad you able to resolve the problem. i will take a look at this problem. and i will make change of the code on next version.

    Thank you

    Post count: 13
    Gouvea
    October 28, 2014 at 5:01 pm #5744

    Could you guys please share a provisional workaround for this issue before the release of the next version? The host will move all websites to new servers running PHP 5.5 next week.

    thanks,

    Post count: 156
    jegtheme
    November 3, 2014 at 1:57 am #6012

    hi gouvea, you can use this code : http://pastebin.com/R1evRwRy
    and put it on jphotolio themes folder > functions > like-function.php

    Thank you

    Post count: 3
    gregwhitephoto
    January 9, 2016 at 12:53 am #17489

    I am having the same or similar problem. Errors on portfolio page showing things like: Warning: mysql_real_escape_string(): Access denied for user ‘root’@’localhost’ (using password: NO) in /home2/gregwhit/public_html/sharkandyeti/wp-content/themes/jphotolio_v453/functions/like-function.php on line 41

    Warning: mysql_real_escape_string(): A link to the server could not be established in /home2/gregwhit/public_html/sharkandyeti/wp-content/themes/jphotolio_v453/functions/like-function.php on line 41

    Is this a problem from my web host? If so, I’m not sure what to ask of them.

    Post count: 3
    gregwhitephoto
    January 9, 2016 at 3:23 pm #17513

    Has this error been corrected in the newest version of jphotolio?
    I am using JPhotolio v4.5.3 and am getting this same error.

    http://www.sharkandyeti.com/portfolio

    Post count: 2483
    Jegbagus
    January 11, 2016 at 2:15 am #17538

    hi gregwhitephoto, yes. you should update your themes. it has been fixed long time ago.

    Thank you

You must be logged in to reply to this topic.