Close

Account

Documentation

Forum

Menu

Mobile menu bug?

  • Post count: 12
    Sofie Theobald
    January 5, 2015 at 5:53 pm #8053

    Hey.

    The main menu for mobile doesn’t seem to work (you know when the menu has shrunk to become just three bars). The sub-menus open and show up but are not working/linking when clicked/touched. Not even on your preview-site as far as I noticed. Any input here? We’ve tried Chrome and Safari.. same error. The site is on http://www.sofietheobald.se

    Thanks!

    Post count: 1921
    Rai
    January 6, 2015 at 1:36 am #8077

    Hi Sofie,

    May I have any screenshot of those issue? Because on our side your mobile menu work just fine. Also, what device that you use to test?

    Thank you

    Post count: 12
    Sofie Theobald
    January 6, 2015 at 9:42 am #8107

    Hi,

    Hmm.. good to know that it works somewhere. 🙂 I’ve tried on iPhone 4 and 5 and iPad in Chrome and Safari. Same thing on desktop (Chrome). The menu works fine when it’s not compressed, but as soon as it is in mobile” (three bars) the linking in the submenues stop working. I’ve attached two images, frontend and backend. I hope that was what you were after.

    Backend

    Frontend

    Thank you!

    Post count: 1921
    Rai
    January 7, 2015 at 2:57 am #8130

    Hi Sofie,

    Well, I just realised that the link on mobile doesn’t work. Don’t worry, we will fix this issue and you can get the update ASAP.

    Thank you

    Post count: 1921
    Rai
    January 7, 2015 at 6:29 am #8131

    Hi Sofie,

    I just fixed those issue and upload the updated theme. Please update your theme 🙂

    Thank you

    Post count: 12
    Sofie Theobald
    January 7, 2015 at 9:14 am #8146

    Hi again,

    Sweet, thanks for the update, unfortunately, there are some issues left: The arrow keeps repeating and sometimes when I hoover on the heading, the submenu keeps folding in and out like a never-ending animation. It looks very strange. Tried this in Chrome and mobile – same thing. Tried to rebuild the menu, but that didn’t fix it, also the whole word in the navigation (for example “About”) is not linked, only the last arrow on that row.

    Arrow down keeps repeating

    Post count: 1921
    Rai
    January 7, 2015 at 12:08 pm #8157

    Hi,

    It seems it happen when you resize your browser, have you tried on your mobile?
    For now please use this CSS to fix that:

    Put those CSS into Appearance > Customize > Custom CSS

    Thank you

    Post count: 12
    Sofie Theobald
    January 7, 2015 at 2:33 pm #8159

    Thanks for the quick reply, but now I get either no arrows, or (without the new code) three arrows when opening the menu on an iPhone. 🙁 Also, it generates a new arrow if I flip the phone to landscape and another one again if I flip it to vertical and so on..

    Post count: 1921
    Rai
    January 8, 2015 at 12:56 am #8171

    Hi Sofie,

    Please remove those custom CSS and use the latest theme instead, I’ve update theme last night.

    Thank you

    Post count: 12
    Sofie Theobald
    January 8, 2015 at 7:18 am #8178

    Hi Rai,

    Thanks for the new update. The arrows finally look good 🙂

    One problem remains though, when I open the menu in my mobile it “bounces” open three times and when I close it, it does so four times. Something is still up with the open/close animation I think. Maybe just a small fix? Thanks you.

    Post count: 1921
    Rai
    January 18, 2015 at 4:01 am #8407

    Hi Sofie,

    It seems your browser load old script. Please try to clear your browser cache first.

    Thank you

    Post count: 12
    Sofie Theobald
    January 22, 2015 at 6:06 pm #8561

    I think that was the case. Now it works. Thank you 🙂

    Post count: 12
    Sofie Theobald
    May 3, 2015 at 2:05 pm #11309

    Hey Rai,

    So I just updated (and yes – I emptyed the Cashce too) the Theme to 1.0.7. and the old problem with the mobile menu appeared again. 🙁 Please visit http://www.sofietheobald.com on your cell to experience it. The problem is that it opens and closes the submenues at the same time. You got some sort of magic code I can paste somewhere? Thanks!

    /Sofie

    Post count: 6364
    Adek
    May 4, 2015 at 7:40 am #11331

    Hi Sofie,

    Can you help me to provide me the login credentials into your wp admin panel, so i can check it directly what actually happen in there. You can send it here and check the Set as private reply option below.

    Thank you

You must be logged in to reply to this topic.