Close

Account

Documentation

Forum

Menu

keywords

  • Post count: 30
    caroline251193
    May 15, 2018 at 7:33 pm #32115

    Hi, I have on all of my pages:
    1. The focus keyword doesn’t appear in the first paragraph of the copy. Make sure the topic is clear immediately.
    2. The keyword density is 0%, which is too low; the focus keyword was found 0 times.
    3. No internal links appear in this page, consider adding some as appropriate.

    Which I have on all of my pages a normal count of keywords, and I don’t understand why it shows like I don’t have them.
    And what does the last one mean?
    Please explain what I need to do

    Post count: 11150
    Adek
    May 16, 2018 at 11:04 am #32144

    Hi caroline251193,

    In this case, did you use a plugin for SEO? Also, may I know where you get that information? so we can replicate it on my side.

    Thank you

    Post count: 30
    caroline251193
    May 16, 2018 at 3:53 pm #32165

    Under the paragraph when I’m on “edit page”.The SEO is actually in green. I’m using the Yoast SEO Premium plugin

    Post count: 30
    caroline251193
    May 16, 2018 at 5:26 pm #32170
    This reply has been marked as private.
    Post count: 11150
    Adek
    May 17, 2018 at 2:28 pm #32212

    Hi caroline251193,

    I’m not quite sure yet, but you may need to contact the Yoast SEO support team. It seems this thing related to your post content and the post keyword.

    For the pictures on the home page, can you provide me a screenshot for a hint? Just want to make sure.

    Thank you

    Post count: 30
    caroline251193
    May 17, 2018 at 4:14 pm #32227

    Sure – please go to https://gevoni.com/, and you will see it straight once the site is loaded ( I cannot paste a screenshot in here)

    Thanks

    Post count: 11150
    Adek
    May 18, 2018 at 9:47 am #32243

    Hi caroline251193,

    You need to re-upload that image with certain image dimension. You need to upload that image with 2:1 dimension. For example, if the width size is 1000px then you need to setup 500px for the height size.

    Thank you

You must be logged in to reply to this topic.