Close

Account

Documentation

Forum

Menu

I have altered the fontawesome but it doesn't update

  • Post count: 29
    fashionmecurvy
    March 21, 2018 at 1:53 am #29770

    I don’t know much about websites or how they store data in ram etc. I have not restarted the server but how do I make it use the new fonts or does jnews pull hte fonts from the web despite fonts being inside the theme?

    Post count: 29
    fashionmecurvy
    March 21, 2018 at 2:18 am #29771

    I checked your css and it points towards the /fonts folder, so I am pretty sure that is where it pulls it from. But I renamed all the files by adding a letter to see if I could break the fonts, but it did not work. My suspicion is that it’s loaded into ram? So server restart to change the fonts?

    Post count: 9454
    Adek
    March 21, 2018 at 9:12 am #29775

    Hi fashionmecurvy,

    For changing the fontawesome you don’t need to restart your server. May i know if you want to upgrade the version of fontawesome or something else? It will help us much if you can tell me more detail about your need in there.

    Thank you

    Post count: 29
    fashionmecurvy
    March 21, 2018 at 8:06 pm #29801

    I saw one of your previous replies about adding custom images to replace social icons. However, since the social icon can appear on the website in several different varieties in several different locations, it is hard create a single image to replace a font symbol.
    My solution was to change the font files. I created a vectorized image of the social icon I needed and replaced a symbol in the font file/s. I then uploaded and was hoping for the best, but it did not work. I then tried to disable all of the fonts by changing the file names like previously mentioned but the website still loaded them without any problems (I know that if I change the path it will break all of the font symbols and display boxes which is what I was hoping for.)

    The social icon I am in need of at the moment is Bloglovin. I replaced the leaf symbol “\f06c” with the bloglovin icon.

    This is what I tried to add (it’s not the best vector image but as small as icons are, the flaws wouldn’t be noticeable)

    svg(generated):
    http://svgur.com/s/5wG

    sfd(some tweaks in fontforge):
    https://ufile.io/4ma9w

    Post count: 9454
    Adek
    March 22, 2018 at 10:31 am #29825

    Hi fashionmecurvy,

    Yeah sure, you can check it on this thread http://support.jegtheme.com/forums/topic/how-to-add-custome-social-icon/#post-28601

    But the solution still depends on your own need. Can you please try to generate your icon into .png file? Then upload it to your website. I think i can provide you CSS code so you can use your image as icon.

    Thank you

    Post count: 29
    fashionmecurvy
    March 22, 2018 at 3:45 pm #29835

    I tried replacing it previously like I mentioned and the problem was that I will have to keep adding more and more css for each and every time the font icon is used. If I ever change the color of the social icons etc I would have to keep replacing the images and produce several different icons to fit into all the different colors. It would be easier in my case to simply change the font, since this would be a permanent solution/ My only problem is that I don’t know how the fonts are loaded since removing the font files off the server doesn’t seem to affect the website at all, so I don’t know how they are loaded.

    Post count: 9454
    Adek
    March 23, 2018 at 10:28 am #29880

    Hi fashionmecurvy,

    You need to use a .png image with transparent background. For example, you can try to use this image https://www.dropbox.com/s/xxb30nho2p7aqt2/bloglovin-icon.png?dl=0.

    For updating the font, i think you’ve been on the right way. But in this case, maybe there’s something issue that makes your font doesn’t update yet. That issue can from your update font or another plugin that use the same font (font awesome) that override theme font.

    Let me know if you have further question.

    Thank you

    Post count: 29
    fashionmecurvy
    March 23, 2018 at 6:02 pm #29889

    I originally made the icon image in a lower bit hence no transparency support since it did not matter if the background was white or transparent for the top social bar. It was not until later that I noticed I needed white font for some other social icons. I could always change them with css but I do prefer the white over the black for those.
    I will just keep trying things until I get the font working.

    It’s most likely like what you said, that another plugin or something is pulling the font from elsewhere, but then why when I change the WordPress address URL and site address URL it breaks the fonts? Shouldn’t that only happen if they are hosted locally?

    Thanks anyway!

    Post count: 29
    fashionmecurvy
    March 23, 2018 at 6:13 pm #29891

    I will try to alter your jeg fonts instead. If that doesn’t work then something on my server is making a copy of all fonts and storing them somewhere…

    EDIT: I edited the file but it doesn’t work with the jegicon either. I tried deleting all the font files in the font folders but it still loads them on the website. I really don’t know what is caching the fonts and how.

    Post count: 29
    fashionmecurvy
    March 23, 2018 at 7:53 pm #29893

    I have now tried to change and delete all of the jegicon font files but none of it affects the website at all. I am now completely clueless as to where the fonts are being loaded. I have disabled all irrelevant plugins etc. I could always try to add a custom font instead and try to load that.

    Post count: 29
    fashionmecurvy
    March 23, 2018 at 8:18 pm #29894

    I just made a custom font instead and linked to that. Problem solved.

    Post count: 2679
    Rai
    March 26, 2018 at 10:47 am #29931

    Hi,

    Could you tell us of what changes you made? If you change the existing font icons, it will be replaced when you update the theme. So, perhaps you could use a child theme for this kind of change and you could update the theme in future safely.

    Thank you

You must be logged in to reply to this topic.