Close

Account

Documentation

Forum

Menu

http Links break my encryption

  • Post count: 21
    pat2858
    September 13, 2016 at 1:10 pm #21875

    Hello,

    on my site
    https://mein-dj-muenchen.de/
    and
    https://mein-dj-muenchen.de/kontakt/
    the encryption is broken due to google maps loaded via http instead of https.
    How can i change this so that the sites are encrypted correctly?

    Thanx
    pat

    Post count: 6441
    Adek
    September 15, 2016 at 3:41 am #21888

    Hi pat2858,

    Sorry for late reply your question. Can you help me to provide login credentials into your wp admin panel so i can check it directly. You can send it here and check the Set as private reply option below.

    Thank you

    Post count: 21
    pat2858
    September 15, 2016 at 6:18 am #21892
    This reply has been marked as private.
    Post count: 6441
    Adek
    September 19, 2016 at 1:31 am #21899

    Hi pat2858,

    I’ve been check your site in there and yeah i see the warning message on the console. But your site will still works fine in there, you don’t need to worry about that.

    Let me know if you have further question.

    Thank you

    Post count: 21
    pat2858
    September 19, 2016 at 5:22 am #21907

    Hi Adek,
    yes, my site works fine, but google maps breaks my encryption. This happens only if i use google maps inside a page. On all other pages there will be no warning. That’s not good for SEO. So i would be very happy if you can tell my how to fix this.

    Thanx
    Pat

    Post count: 6441
    Adek
    September 19, 2016 at 7:18 am #21908

    Hi Pat,

    If so, i will need to access the themes file on your server because i will need to make small changes on certain file, or you can install this plugin on your site.

    Thank you

    Post count: 21
    pat2858
    September 19, 2016 at 10:42 am #21912

    Installed the plugin.

    Greetz
    Pat

    Post count: 6441
    Adek
    September 22, 2016 at 1:46 am #21925

    Hi Pat,

    I’ve been fix the issue. But please check if you’ve been using valid key google maps.

    Thank you

    Post count: 21
    pat2858
    September 22, 2016 at 8:44 am #21928

    Thank you very much.
    I created a new google api key, but i get this message:

    Google Maps API error: DeletedApiProjectMapError https://developers.google.com/maps/documentation/javascript/error-messages#deleted-api-project-map-error

    The api key shown in the console is not that api key i set in the template-dashboard.

    Don’t know what happens here.

    Post count: 21
    pat2858
    September 22, 2016 at 10:44 am #21929

    is it possbile, that this wrong api key is hard-coded in the theme files anywhere?

    Post count: 6441
    Adek
    September 26, 2016 at 2:43 am #21950

    Hi pat2858,

    May i know which API key that you mean on above, i just want to make sure on this thing.

    https://www.dropbox.com/s/8imf0aajb249l6t/Screenshot%202016-09-26%2010.41.12.png?dl=0
    https://www.dropbox.com/s/1hfgv9zwdeh20dz/Screenshot%202016-09-26%2010.41.00.png?dl=0

    Thank you

    Post count: 21
    pat2858
    September 26, 2016 at 9:26 am #21953

    This is the right key (AIzaSyD7…). I entered it at the JKreativ Dashboard and it works on the Homepage, as you see.
    Please take a look at the contact page: https://mein-dj-muenchen.de/kontakt/
    There i get a error message with the wrog key:
    js?key=AIzaSyD3Asn…:37 Google Maps API error: DeletedApiProjectMapError
    Where is the key AIzaSyD3… getting from?

    Post count: 6441
    Adek
    September 28, 2016 at 3:37 am #21963

    Hi pat2858,

    I’ve been check your site previously and i see the problem as you said on above. Please check again, the problem has been fixed.

    Thank you

    Post count: 21
    pat2858
    September 28, 2016 at 6:07 am #21965

    Fixed now! Thank you!

    Post count: 6441
    Adek
    September 30, 2016 at 3:40 am #21983

    You’re welcome pat2858

    Thank you

You must be logged in to reply to this topic.