Close

Account

Documentation

Forum

Menu

Fatal error after theme update

  • Post count: 130
    medialifesf
    April 24, 2015 at 8:22 am #11147

    Hi! I updated my JKreativ theme today via Envato Toolkit because I received a message for Update available.

    My website is working with activated child theme. But after this last update when my child theme is activated, I receive the following error:

    Fatal error: Call to undefined function jeg_generate_random_string() in …/wp-content/themes/jkreativ-themes/vc_templates/vc_row.php on line 83

    Can you tell me what is the reason for that?

    Post count: 6700
    Adek
    April 25, 2015 at 7:23 pm #11174

    Hi medialifesf,

    May i know what the current version of Jkreativ that you use on your site?

    Thank you

    Post count: 130
    medialifesf
    April 26, 2015 at 8:07 pm #11203

    The Jkreativ theme is Version: 2.2.8

    Post count: 130
    medialifesf
    April 26, 2015 at 8:13 pm #11204

    Also my WPBakery Visual Composer is version 4.3.5 installed. But the update to 4.4.4 gives an error:
    An error occurred while updating WPBakery Visual Composer: To receive automatic updates license activation is required. Please visit Settings to activate your Visual Composer.
    It needs Visual Composer License Key (CodeCanyon Visual Composer license key) but where is this key?

    Post count: 6700
    Adek
    April 27, 2015 at 7:56 pm #11227

    Hi medialifesf,

    Can you help me to provide me login credentials into your wp admin panel, i will need to check it directly on my side and see what actually happen in there.

    Thank you

    Post count: 14
    Evocom
    May 4, 2015 at 8:18 am #11335

    Hello,

    Same problem … Where can we find the visual composer key ?

    Best regards

    Post count: 6700
    Adek
    May 4, 2015 at 5:13 pm #11359

    Hi Evocom,

    May i know if you want to updating those plugin right? Actually you don’t need license key of those plugin because we’ve been bundle those plugin file with our theme.

    Let me know if you have further question.

    Thank you

    Post count: 98
    finalcut47
    May 6, 2015 at 10:47 am #11430

    Help. I upgraded to 2.2.9 and now the site is not working. It remains stuck with the image of the loader. Trying to change the loader I get the same error medialifesf at line 83. I am still, help

    Post count: 6700
    Adek
    May 7, 2015 at 8:23 am #11479

    Hi finalcut47,

    Did you use child theme on your site? If so please use parent theme and also may i know what the current version of the Visual Composer plugin that you use?

    Thank you

    Post count: 98
    finalcut47
    May 7, 2015 at 10:21 am #11485

    Yes use the child theme . the current version of the Visual Composer plugin That I use is 4.4.2 ( but in the documentation of the ZIP file -js_composer.zip – is written 4.4.3 ) ???

    Post count: 98
    finalcut47
    May 7, 2015 at 10:43 am #11488

    OK with parent theme the site works, but so I LOST ALL CUSTOM. There is no absolute remedy to continue to use the child theme? Thanks

    Post count: 6700
    Adek
    May 8, 2015 at 11:54 am #11528

    Hi finalcut47,

    Sorry for late reply your message previouly. Please try to update your theme version into latest version of Jkreativ themes. We’ve been released the new version a few days ago and also disable all plugin for a while after that.

    Thank you

    Post count: 98
    finalcut47
    May 8, 2015 at 4:44 pm #11545

    So, I downloaded the new release and I published on my server. After some tests, I realized that the problem is caused by the plugin js.composer 4.4.3. When I deactivate (using the child theme) the site run, but of course does not play as expected, and display … [vc_row section_top_margin=”normaltopmargin” section_bottom_margin=”normalbottommargin” section_schema=”normal” section_background=”color” background_color=”#bc0000″ … ecc …]. Instead using the father theme the site works but all the customizations made on the child of course there are not. I also deleted and reloaded plugin, but there is nothing to do. What do I do ?

    Post count: 6700
    Adek
    May 9, 2015 at 11:38 am #11555

    Hi finalcut47,

    May i know what kind of customizations that you’ve been made in there?

    Thank you

    Post count: 98
    finalcut47
    May 9, 2015 at 1:29 pm #11556

    Mainly I edited the following files:
    1) htdocs \ wordpress \ wp-content \ themes \ jkreativ-themes \ template \ blogpost \ article-meta.php
    2) htdocs \ wordpress \ wp-content \ themes \ jkreativ-themes \ lib \ themes-functionality.php
    3) htdocs \ wordpress \ wp-content \ themes \ jkreativ-themes \-blog-comments clean.php
    For an Italian translation. I can not remember the other but it’s been months.
    But the blog page actually works, probably because it was NOT created with WPBakery visual composer …
    But the question is: why the child theme is not working (see error reported at the beginning of the post) and the father yes ?.

You must be logged in to reply to this topic.