Close

Account

Documentation

Forum

Menu

Zero width space for Cambodian Language (Khmer)

  • Post count: 48
    Poli2016
    July 11, 2018 at 12:11 pm #33958

    Hi, Recently I found that my Cambodian article (Khmer language) is not well display in many important browsers, except Google Chrome is okay. I can explain here, I write my Khmer language in Khmer Unicode keyboard system, this is an example for you in my language:
    “I go to market with my sister”. In Khmer language “Igotomarket withmysister.”, but almost of my sentences have many words without space.
    Here is my bad post: https://tvsiemreap.com/2018/07/08/local-news/259/
    Here is a clean post : http://bayontv.com.kh/2018/07/11/3807/
    please look at the right side of the article, clean post has no long space.

    I found this site: https://www.sbbic.org/2016/08/24/fix-khmer-zero-width-space-issue-wordpress/ to fix my problem. Unfortunately, when I replaced “default wordpress tinymce” in this directory “/wp-includes/js/tinymce” my post editor has no tools anymore.

    Please advise to use Zero width space in WordPress TinyMCE, thank you.

    Post count: 462
    Aldhi
    July 11, 2018 at 2:25 pm #33963

    Hi Poli2016,

    It seems that issue causing by Minify HTML output feature. Please try to disable it on the Customize > JNews Speed Option > HTML Option > disable Minify output option.

    Thank you

    Post count: 48
    Poli2016
    July 11, 2018 at 7:58 pm #33970

    Hi Aldhi, I’ve tried to look for this Customize > JNews Speed Option > HTML Option > disable Minify output option., but I didn’t find it!

    • This reply was modified 3 months, 1 week ago by  Poli2016.
    Post count: 10705
    Adek
    July 12, 2018 at 9:46 am #33981

    Hi Poli2016,

    May i know if you’re using JNews Speed plugin in there? If yes, you should found the option on the Customizer.

    Also, for replacing the default WordPress tinymce it’s a bit risky. Because your changes will be lost when doing WordPress update. So you will need to put the changes again after doing an update. Regarding this issue, please try to clear your browser cache to refresh the js file. Also if you’re using Cloudflare you may need to disable it for a while.

    Thank you

    Post count: 48
    Poli2016
    July 12, 2018 at 11:49 am #33989

    Hi, Thank you Adek, I haven’t installed JNews Speed plugin for my website. I don’t use Cloudflare.
    I already cleared cached my browser, but it still doesn’t work. Can you advise me other solutions? Or Should I automatically add “zero width space” to all my article in code?

    Post count: 462
    Aldhi
    July 12, 2018 at 3:36 pm #33996

    Hi Poli2016,

    I’m not quite sure about this issue, because of I’m not familiar with your language. Also, I was searching on google and this is a common issue in your language. I don’t have a solution yet, but I’ll contact you as soon if I find any solution.

    Thank you.

    Post count: 48
    Poli2016
    July 12, 2018 at 7:26 pm #34000

    Hi Aldhi, thank you. I may bother you again, I’d like to install a new TinyMCE, is it possible to replace the default WordPress TinyMCE?
    Here is TinyMCE for my language https://github.com/tinymce/tinymce/tree/1696e387e818d9c3f4e2e2d8871f0218208a0212

    If I can install, can you instruct me to install it in wordpress? I’ve tried on my best to install it, but I can’t. This is important for my website.

    Post count: 2684
    Rai
    July 13, 2018 at 10:33 am #34013

    Hi,

    Actually, the TinyMCE editor is a WordPress core script, it should be possible but would require a custom change to override the core script, or you may consider adding 3rd party plugin such as: TinyMCE Advanced.

    Thank you

    Post count: 48
    Poli2016
    July 13, 2018 at 11:21 am #34016

    Hi Rai, thank you. I’ve installed TinyMCE Advance, anyway I don’t know how to customise it, I’d need to to add zero-width space to the whole of my posts. Can you help me to to do it?

    Post count: 462
    Aldhi
    July 13, 2018 at 2:24 pm #34018

    Hi Poli2016,

    To customize it you can go to your Dashboard>Settings>TinyMce Advance > then drag the “unused buttons” you want to the “editor menu” then save the changes.

    Thank you.

    Post count: 48
    Poli2016
    July 13, 2018 at 6:14 pm #34029

    Hi Aldhi, Thank you. I went to this setting, but I can’t find how to add Zero-width Space in my post. Do you have any ideas with Zero-width Space in TinyMCE Advanced?

    Post count: 10705
    Adek
    July 16, 2018 at 10:08 am #34047

    Hi Poli2016,

    About the TinyMCE Advanced plugin, it seems they don’t have zero width space option.

    Also, for replacing the core TinyMCE on WordPress is not good i think, because it can be generating some compatibility issue and it will be lost when you’re updating WordPress.

    Previously, I just play around on my localhost and it seems you may try to use CSS code to decrease the width space. In this case, do you want to decrease the width space, right? I just want to make sure again. If yes, please try to use this CSS code below and put them on the Additional Style:

    The code above will affect on the paragraph text only. You can adjust the word spacing value. If it’s work, i will provide you the CSS for other HTML tags such as heading, span, etc.

    Thank you

    Post count: 48
    Poli2016
    July 30, 2018 at 10:10 am #34575

    Hi Adek, thanks for your solution, anyway, it didn’t work. Thank you again.

    Post count: 462
    Aldhi
    August 1, 2018 at 11:14 am #34758

    Hi Poli2016,

    We are sorry for the inconvenience. I think it’s related to the font or the browser issue. If we find some solution, we will contact you ASAP.

    Thank you

You must be logged in to reply to this topic.