Close

Account

Documentation

Forum

Menu

WPML For Home Page and Portfolio Pages

  • Post count: 13
    pmanning11
    May 29, 2015 at 1:49 am #11988

    Hello,

    I installed the wpml plugin and it works fine for posts but for the home page and portfolio pages it just brings up a 404 error. The link is suppose to go from website.com/accommodations to website.com/es/comidades but the link only shows website.com/es/. A spanish version of the page is made.

    Thanks,

    Phil

    Post count: 6700
    Adek
    May 30, 2015 at 8:56 am #12023

    Hi Phil,

    Can i see your site, i will check it directly on my side.

    Thank you

    Post count: 13
    pmanning11
    May 30, 2015 at 4:52 pm #12024
    This reply has been marked as private.
    Post count: 6700
    Adek
    June 2, 2015 at 11:33 am #12049

    Hi Phil,

    I’ve received your info, but can you provide me the url of your site as well?

    Thank you

    Post count: 13
    pmanning11
    June 2, 2015 at 5:01 pm #12064
    This reply has been marked as private.
    Post count: 6700
    Adek
    June 3, 2015 at 11:38 am #12076

    Hi Phil,

    I’ve been make a small change in there. You can check this page http://www.dreamcatcherhotel.com/accommodations/ (english) and http://www.dreamcatcherhotel.com/es/comidades/ (spanish)

    Thank you

    Post count: 13
    pmanning11
    June 3, 2015 at 4:52 pm #12082

    Hey Dek,

    Thanks I can see that page is working now. Could you send me a screenshot of how you created that page? I click on the + button on each page, but I can’t seem to make the same changes for the other pages/portfolio pieces/etc.

    Thanks again,

    Phil

    Post count: 13
    pmanning11
    June 3, 2015 at 11:22 pm #12084

    Hey Dek,

    I think I figured it out. It was a bit hacky but let me know if this is how you did it…
    1) I had to press the + button to add a new page to enable the duplicate checkbox.
    2) Go back to the page and check the Duplicate checkbox and click the Duplicate button
    3) Delete the newly created page from the + button
    4) Click on the edit icon, wherever, to access the other language page

    Thanks

    Phil

    Post count: 6700
    Adek
    June 4, 2015 at 9:10 am #12091

    Hi Phil,

    I’m not quite sure, but I do it slightly differently. You just need to go edit the page that you want to translate. Then on the Language metabox option you can choose add translation or duplicate option.

    Thank you

You must be logged in to reply to this topic.