Close

Account

Documentation

Forum

Menu

Translation issues

  • Post count: 7
    televiziunealibera
    November 21, 2017 at 7:40 pm #25780

    Hi,
    First of all I want to congratulate you for the great work you did with this theme.
    I hope you can help me with 2 issues I have trying to translate my pages and posts. I use polylang plugin for translations. It works very well with your translation plugin, kudos for that.

    My first issue I have is with 2 strings from the footer: “Site Navigation” and “Follow us” that are not marked for translation. I understand that these 2 string are custom strings, but if I want to translate them what would be the recommended way to do it?

    My second issue is not so obvious. I have several very simple pages and posts. Each page and post is translated into 3 languages. For the posts, I use a the “second title” field. But I observed that all the translations of the same post share the same “second title” text. For example, let’s say I have “myPost-eng” and “myPost-fr” that are translations of the same post. They are related in Polylang. The “second title” fields of both posts contain the same text even if I’ve entered different texts. Is like when I update one post it will update the other one too.

    That’s all for me.

    Thanks,

    Claudiu

    Post count: 2281
    Rai
    November 22, 2017 at 1:21 am #25798

    Hi Claudiu,

    Thank you for your kind words.

    1) Is it a Widget title? For widget you need to create instance for each language.

    2) When creating new post for other language, you need to change the sub title. If it doesn’t work, could you provide me login detail so we can investigate it further? Please reply as private if you provide sensitive information.

    Please let us know if you have further questions.

    Best regards,
    Rai

    Post count: 7
    televiziunealibera
    November 22, 2017 at 3:33 pm #25829
    This reply has been marked as private.
    Post count: 7
    televiziunealibera
    November 22, 2017 at 6:46 pm #25832
    This reply has been marked as private.
    Post count: 2281
    Rai
    November 23, 2017 at 1:25 am #25838

    Hi Claudiu,

    1) Thank you for your confirmation. We will work on adding this to polylang string translations.

    2) I have checked on your server and it is weird, this is not happen on our end. The subtitle translation is working just fine on our server. We will investigate it further and provide you update.

    Thank you

    Post count: 7
    televiziunealibera
    November 23, 2017 at 3:13 pm #25868
    This reply has been marked as private.
    Post count: 2281
    Rai
    November 24, 2017 at 12:34 am #25882

    Hi Claudiu,

    It could be, please try to disable other 3rd party plugins but keep the required plugins.
    We unable to replicate the issue on our end, but will keep investigating it.

    Thank you

    Post count: 7
    televiziunealibera
    November 24, 2017 at 5:22 pm #25934
    This reply has been marked as private.
    Post count: 7547
    Adek
    November 27, 2017 at 9:38 am #26030
    This reply has been marked as private.
    Post count: 7
    televiziunealibera
    November 27, 2017 at 9:48 pm #26085
    This reply has been marked as private.
    Post count: 7
    televiziunealibera
    November 27, 2017 at 10:05 pm #26087
    This reply has been marked as private.
    Post count: 2281
    Rai
    November 28, 2017 at 8:51 am #26112

    Hi Claudiu,

    Please follow this instruction for updating theme: http://support.jegtheme.com/documentation/themes-update/

    If you want to use child theme, yes you need to upload both (parent & child) jnews-theme.zip and jnews-child.zip.
    Yes, all customization will be reset if you change theme, but you could use this export/import plugin: https://wordpress.org/plugins/customizer-export-import/ so you able to replicate the previous customization on customizer.

    Thank you

    Post count: 7
    televiziunealibera
    December 1, 2017 at 12:34 am #26295

    Hi Rai,

    I’ve built everything from scratch with the update files and I managed to find the culprit for the translation issue. The polylang plugin has a setting called “Synchonization”. As soon as I checked all the boxes for this setting, the translation problem appeared. I unchecked “Taxonomies” and “Custom Fields” and the problem disappeared.

    Thanks for your help.

    Post count: 2281
    Rai
    December 1, 2017 at 9:33 am #26311

    Hi @televiziunealibera,

    So glad to hear it! Thank you for letting us know.

    Best regards,

You must be logged in to reply to this topic.