Close

Account

Documentation

Forum

Menu

SSL bug with theme

  • Post count: 9
    jfrancais
    March 2, 2017 at 9:46 pm #23221

    Found a bug, when I switched my site to SSL I was getting errors with certain URLS trying to load over non SSL. Tracked it to fonts.googleapi urls. I made chances to init-register.php and admin.js to remove http: in front of fonts.googleapi urls. 3 in total. fixed the bug.

    Can this be put into the theme so I don’t need to fix in a child theme?

    • This topic was modified 2 months, 3 weeks ago by  jfrancais.
    Post count: 5813
    Adek
    March 3, 2017 at 2:11 am #23227

    Hi jfrancais,

    Thank’s for your info, really appreciate it. We will include this fix to next theme update.

    Let us know if you need something else in there.

    Regards

    Post count: 9
    jfrancais
    March 3, 2017 at 9:19 pm #23230

    It appears there are more than just these 3. I didnt notice them as I had a plug in enabled that was fixing others. When I disabled that plugin I could see more errors. I see these ones in particular being referenced somewhere:

    http://www.youtube.com/player_api
    http://connect.facebook.net/en_US/all.js
    http://platform.twitter.com/widgets.js

    I havent located the spots in code to fix.

    Post count: 5813
    Adek
    March 4, 2017 at 1:52 am #23231

    Hi jfrancais,

    Can you help me to provide your site url, i will check it directly on my side.

    Thank you

    Post count: 9
    jfrancais
    March 4, 2017 at 9:43 pm #23234

    I already fixed it on my site. I had to make a few more additional changes.

    In the init-default.default.php file I removed the http from the front of the following:

    //www.youtube.com/player_api
    //connect.facebook.net/en_US/all.js#xfbml=1
    //platform.twitter.com/widgets.js

    I no longer have any SSL errors appearing in my site.

    Post count: 5813
    Adek
    March 6, 2017 at 1:49 am #23236

    Hi jfrancais,

    Glad to hear that, let us know if you need something else.

    Thank you

You must be logged in to reply to this topic.