Close

Account

Documentation

Forum

Menu

Register account error

  • Post count: 5
    antonis
    May 13, 2015 at 12:38 pm #11639

    When I Enable registration on the “My Account” page in Woocommerce settings, Register button shows up in the menu icon but doesn’t work.
    When somebody tries to register account through menu icon never completes the procedure and shows no error message.
    Digging around forums people say that the problems is coming from theme’s woocommerce template files.
    Please advise.

    Post count: 5936
    Adek
    May 14, 2015 at 8:40 am #11663

    Hi antonis,

    Can i see your site, so i can check it directly on my side. Also may i know current version of WooCommerce plugin that you use and Jkreativ themes as well?

    Thank you

    Post count: 5
    antonis
    May 14, 2015 at 8:54 am #11664

    Hi,
    The site is wwww.ritualbloom.com and I’m using woocommerce version 2.3.8
    Do you need login credentials etc.?

    Post count: 5936
    Adek
    May 15, 2015 at 5:17 pm #11686

    Hi antonis,

    Yes sure, it would be better if you can provide me login credentials into your wp admin panel so i can take a look more closer what actually happen in there.

    Thank you

    Post count: 5
    antonis
    May 16, 2015 at 10:49 pm #11704
    This reply has been marked as private.
    Post count: 5936
    Adek
    May 19, 2015 at 8:29 am #11726

    Hi antonis,

    Sorry for late reply your message.

    I’ve been check your site. Please try to disable all plugins except required plugins that come with Jkreativ themes. Also can you use the parent theme for a while, i just want to make sure if there is no conflict between additional plugin and your customization on the child theme.

    Thank you

    Post count: 70
    Truedacolor
    February 10, 2016 at 5:30 am #18369

    Hi i was going to post a new threat but it seens it is old, can i get some help over here with this issue,

    i made a new installation of your theme to see in it was any of my plugins or custom configuration,

    in a blank and fresh install, the woocommerce cant register any one, just through back end, AND i found that under the checkout page it is possible to register.

    but not by demand, again please help with this issue

    Post count: 70
    Truedacolor
    February 10, 2016 at 7:10 am #18370

    Found a Fix, i change the code a bit in wp-content/themes/jkreative/woocommerce/myaccount/form.login.php

    if you are so kind to checked if the rest of the code is not working and if is getting al variables necessary to maintain function, i just change the line around 110 it reads something like (‘register’,’register’) ?> and i change to (‘woocommerce-register’) ?> and start to work and registering users i check the back end nad users are there.. hope this is helpful for the community

    the code is

    <?php

    /**

    * Checkout login form

    *

    * @author WooThemes

    * @package WooCommerce/Templates

    * @version 2.2.6

    */

    if ( ! defined( ‘ABSPATH’ ) ) exit; // Exit if accessed directly

    ?>

    <div class=”contentheaderspace”></div>

    <div class=”pagewrapper pagecenter halfwidth nosidebar registerpage”>

    <div class=”pageholder”>

    <div class=”pageholdwrapper”>

    <div class=”mainpage blog-normal-article”>

    <div class=”accordion-wrapper”>

    <div class=”halfpagepanel”>

    <?php if (get_option(‘woocommerce_enable_myaccount_registration’) == ‘yes’) : ?>

    <div class=”halfpagepanel-header”>

    <i class=”fa fa-key halfpage-icon”></i>

    <span class=”ocindicator”></span>

    <?php _e(‘Customer Login’, ‘jeg_textdomain’) ?>

    </div>

    <?php endif; ?>

    <div class=”halfpagepanel-body”>

    <div class=”pageinnerwrapper”>

    <div class=”article-header”>

    <h3><?php _e(‘Customer Login’, ‘jeg_textdomain’) ?></h3>

    </div>

    <?php

    wc_print_notices();

    do_action(‘woocommerce_before_customer_login_form’);

    ?>

    <div class=”article-content”>

    <form method=”post” class=”login”>

    <?php do_action( ‘woocommerce_login_form_start’ ); ?>

    <p class=”form-row”>

    <label for=”username”><?php _e( ‘Username or email’, ‘jeg_textdomain’ ); ?> <span class=”required”>*</span></label>

    <input type=”text” class=”input-text” name=”username” id=”username” />

    </p>

    <p class=”form-row”>

    <label for=”password”><?php _e( ‘Password’, ‘jeg_textdomain’ ); ?> <span class=”required”>*</span></label>

    <input class=”input-text” type=”password” name=”password” id=”password”>

    </p>

    <?php do_action( ‘woocommerce_login_form’ ); ?>

    <div class=”clearfix”></div>

    <p class=”form-row”>

    <?php wp_nonce_field( ‘woocommerce-login’ ); ?>

    <input type=”submit” class=”btn btn-primary” name=”login” value=”<?php _e( ‘Login’, ‘woocommerce’ ); ?>” />

    <label for=”rememberme” class=”inline”>

    <input name=”rememberme” type=”checkbox” id=”rememberme” value=”forever” /> <?php _e( ‘Remember me’, ‘woocommerce’ ); ?>

    </label>

    </p>

    <p class=”lost_password”>

    “><?php _e( ‘Lost your password?’, ‘woocommerce’ ); ?>

    </p>

    </form>

    </div>

    <div class=”clearfix”></div>

    </div>

    </div>

    </div>

    <?php if (get_option(‘woocommerce_enable_myaccount_registration’) == ‘yes’) : ?>

    <div class=”halfpagepanel”>

    <div class=”halfpagepanel-header”>

    <i class=”fa fa-lock halfpage-icon”></i>

    <span class=”ocindicator”></span>

    <?php _e(‘Register New Account’, ‘jeg_textdomain’) ?>

    </div>

    <div class=”halfpagepanel-body”>

    <div class=”pageinnerwrapper”>

    <div class=”article-header”>

    <h3><?php _e(‘Register New Account’, ‘jeg_textdomain’) ?></h3>

    </div>

    <div class=”article-content”>

    <form method=”post” class=”login”>

    <?php if ( get_option( ‘woocommerce_registration_email_for_username’ ) == ‘no’ ) : ?>

    <p class=”form-row”>

    <label for=”reg_username”><?php _e( ‘Username’, ‘jeg_textdomain’ ); ?> <span class=”required”>*</span></label>

    <input type=”text” class=”input-text” name=”username” id=”reg_username” value=”<?php if (isset($_POST[‘username’])) echo esc_attr($_POST[‘username’]); ?>” />

    </p>

    <?php endif; ?>

    <p class=”form-row”>

    <label for=”reg_email”><?php _e( ‘Email’, ‘jeg_textdomain’ ); ?> <span class=”required”>*</span></label>

    <input type=”email” class=”input-text” name=”email” id=”reg_email” value=”<?php if (isset($_POST[’email’])) echo esc_attr($_POST[’email’]); ?>” />

    </p>

    <p class=”form-row”>

    <label for=”reg_password”><?php _e( ‘Password’, ‘jeg_textdomain’ ); ?> <span class=”required”>*</span></label>

    <input type=”password” class=”input-text” name=”password” id=”reg_password” value=”<?php if (isset($_POST[‘password’])) echo esc_attr($_POST[‘password’]); ?>” />

    </p>

    <p class=”form-row”>

    <label for=”reg_password2″><?php _e( ‘Re-enter password’, ‘jeg_textdomain’ ); ?> <span class=”required”>*</span></label>

    <input type=”password” class=”input-text” name=”password2″ id=”reg_password2″ value=”<?php if (isset($_POST[‘password2’])) echo esc_attr($_POST[‘password2’]); ?>” />

    </p>
    <?php do_action( ‘woocommerce_register_form’ ); ?>
    <?php do_action( ‘register_form’ ); ?>

    <p class=”form-row”>
    <?php wp_nonce_field( ‘woocommerce-register’ ); ?>
    <input type=”submit” class=”btn btn-primary” name=”register” value=”<?php _e( ‘Register’, ‘jeg_textdomain’ ); ?>” />
    </p>

    <?php do_action( ‘woocommerce_register_form_end’ ); ?>

    </form>

    </div>

    <div class=”clearfix”></div>

    </div>

    </div>

    </div>

    <?php endif; ?>

    <?php do_action(‘woocommerce_after_customer_login_form’); ?>

    </div>

    </div>

    </div>

    </div>

    </div>

    <script>

    (function($) {

    $(document).ready(function() {

    $(“.mainpage”).jnormalblog();

    $(“.mainpage”).jaccordionpage();

    });

    })(jQuery);

    </script>

    Post count: 5936
    Adek
    February 12, 2016 at 7:30 am #18429

    Hi Truedacolor,

    Thanks for your help on this thing, really appreciate it 🙂

    We will take a look on this thing.

    Thank you

You must be logged in to reply to this topic.