Close

Account

Documentation

Forum

Menu

Problem with the images in AMP

  • Post count: 56
    Communication Contact
    November 11, 2017 at 2:44 am #25300

    Hi,

    I have a problem with the images in AMP, I’m using the Accelerated Mobile Pages plugin

    which with the old thema Newsmag has always worked.

    The problem is that it loads Full image and not the thumbnail, as it did in the old thema.

    https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fwww.knews.it%2Famp%2F&tab=desktop

    I had a score of 90/100 on mobile and 96/100 on Desk

    Now only 60/100 on mobile and 61/100 on Desk

    Here are some examples of pages

    https://www.knews.it/treno-freccia-argento-deraglia-a-firenze-gli-ultimi-aggiornamenti-sullaccaduto-9270/amp/

    https://www.knews.it/cronaca/amp/

    https://www.knews.it/amp/

    I need a solution, thank you and good work

    Post count: 56
    Communication Contact
    November 12, 2017 at 1:14 pm #25327

    Hi,

    but are there some news ??

    Post count: 2448
    Jegbagus
    November 13, 2017 at 2:43 am #25359

    hi Communication Contact, your website (amp) is not using our AMP.
    but using other people AMP plugin.

    also why do you need to test your load speed your page using AMP ?
    as i know, google will cache the result of your page when you using AMP (Google Search).
    and it will load your website instantly simply because google already load your amp search result when you click the result.

    honestly i think its not quite right to test AMP page with google speed.

    Thank you

    Post count: 56
    Communication Contact
    November 13, 2017 at 7:42 am #25372

    Hi,

    with other Newsmag themes The Accelerated Mobile Pages plugin uses images of 300 px no full image and therefore works fine.

    While using your plugin uses full images, I’ve also put the links to see this problem.

    Certainly, it’s just a simple function to take 300 px images and not as full from the Accelerated Mobile Pages plugin.

    This plugin is much more used than the AMP plugin you tested, as it has a lot of features.

    I look forward to your feedback.

    Post count: 56
    Communication Contact
    November 13, 2017 at 3:11 pm #25395

    Hi,

    do you have any news for this problem ??

    Post count: 6436
    Adek
    November 14, 2017 at 12:47 am #25402

    Hi Communication Contact,

    I’ve tried to test it on my side. For the images, do you mean the featured image in the related post content? If yes, please try to regenerate all of your images. Because we use 120x86 dimension for the featured image of related post. You can try to use Regenerate Thumbnail plugin.

    Thank you

    Post count: 56
    Communication Contact
    November 14, 2017 at 1:19 am #25413

    hi,

    when I changed thema, I’ve already used the Regenerate Thumbnail Plugin, of course to create the new images that thema needs.

    But that does not work.

    you can also control yourself

    Example:

    https://www.knews.it/wp-content/uploads/2017/11/treno-min-120x86.jpg

    Post count: 6436
    Adek
    November 14, 2017 at 1:52 am #25420

    Hi Communication Contact,

    Please try to update this file /wp-content/themes/jnews/class/Image/Image.php then jump into line 67. Replace this code below :

    With this one below :

    After you have done with this changes, you need to regenerate all of your images again.

    Thank you

    Post count: 56
    Communication Contact
    November 14, 2017 at 2:11 am #25422

    Hi,

    I made the change, as you have recommended me, and it works …

    Great idea.

    I wanted to know if I now have to edit those two files again ???

    Or do I have to do anything and leave it all so, of course, will it be in the next update ???

    Post count: 6436
    Adek
    November 14, 2017 at 2:39 am #25423

    Hi Communication Contact,

    We have been including this change for next theme update. So, you don’t need to update that file again 🙂

    Thank you

You must be logged in to reply to this topic.