Close

Account

Documentation

Forum

Menu

Problem with portfolio list page pagination

  • Post count: 34
    andre_placido
    February 6, 2015 at 1:05 am #8892

    Hi!

    I’ve changed the file “template-portfolio.php” so that the portfolio would be listed from the most recent to the oldest projects.

    To do so, I just changed the command “‘order’ => ‘ASC’,” to “‘order’ => ‘DESC’,”.

    It worked out, however, my portfolio page has 3 pages now, but when I go to page 3 and come back to page 1, the order is different.

    What is happening? Can you help me fix it?

    The page is http://ricardoalmeida.arq.br/portfolio/

    Thank you!

    Post count: 34
    andre_placido
    February 8, 2015 at 9:52 pm #8938

    Hello! Has anyone seen my message? Do you need some more information about my issue?

    Thanks!

    Post count: 34
    andre_placido
    February 10, 2015 at 12:26 am #8953

    Hello! I’m sorry to insist, but is anyone checking my issue? I really need to get this solved!

    Thanks!

    Post count: 6364
    Adek
    February 10, 2015 at 9:27 am #8983

    Hi andre_placido,

    Sorry for late reply your message. May i know if you’ve change the query order by as well?

    Thank you

    Post count: 34
    andre_placido
    February 10, 2015 at 11:18 pm #9018

    Hi Dek Ery! No, I haven’t changed this query.

    What I need is this page to be ordered by the date they were added, if changing this query solves the problem, then It’s ok for me, as long as the pagination stays correct.

    What should I do?

    Thank you

    Post count: 6364
    Adek
    February 12, 2015 at 9:51 am #9145

    Hi andre_placido,

    If so you can try to change the order by so it’s look like :

    You can change the filter (date) with date, date_add or date_create.

    Thank you

    Post count: 34
    andre_placido
    February 14, 2015 at 11:58 pm #9259

    Thanks Dek, however, the problem still remains… I think it’s with the “DESC” command. I tried to set it, but when I turn to page 3 on my portfolio, it’s equal to page 1 again. If I set the order do “ASC” this doesn’t happen.

    Can you help me?

    Post count: 6364
    Adek
    February 17, 2015 at 8:15 am #9393

    Hi andre_placido,

    Can you provide me access into your wp admin, i will check your portfolio list in this case. You can send it here and check the Set as private reply option below.

    Thank you

    Post count: 34
    andre_placido
    February 17, 2015 at 3:21 pm #9413
    This reply has been marked as private.
    Post count: 6364
    Adek
    February 20, 2015 at 12:09 pm #9467

    Hi andre_placido,

    Sorry for late reply your message. But i’m not quite sure about your site above, because it doesn’t using JKreativ themes.

    Also may i know which file that you change the code (the sql query)?

    Thank you

    Post count: 34
    andre_placido
    February 20, 2015 at 12:39 pm #9471
    This reply has been marked as private.
    Post count: 6364
    Adek
    February 21, 2015 at 9:53 am #9509

    Hi andre_placido,

    I’ve been tried several thing, but i get the same result. But when it try to load all of your portfolio item on one page, its just work fine. It’s weird for me.

    Thank you

    Post count: 34
    andre_placido
    February 21, 2015 at 1:41 pm #9511

    Ok, so what can you do about it?

    You can’t just leave it, right?

    Post count: 6364
    Adek
    February 24, 2015 at 12:06 pm #9595

    Hi andre_placido,

    It’s seems you need to load all of your portfolio into one page, in this case to listed from the most recent to the oldest projects.

    Thank you

    Post count: 34
    andre_placido
    March 2, 2015 at 12:58 am #9699

    The problem with that is that the page takes too much to download… Can you provide an update to solve this problem?

You must be logged in to reply to this topic.