Close

Account

Documentation

Forum

Menu

Portfolio URLs Giving 404 Errors

  • Post count: 9
    DepecheCode
    June 20, 2014 at 8:01 pm #486

    So I have set up some portfolios and have put in the code:

    [portfolio-wrapper parent=”420″]

    [portfolio-item id=”420″ width=”1/3″ height=”1″]

    [portfolio-item id=”421″ width=”2/3″ height=”2″]

    [portfolio-item id=”422″ width=”1/3″ height=”2″]

    [portfolio-item id=”423″ width=”1/3″ height=”1″]

    [portfolio-item id=”424″ width=”1/3″ height=”1″]

    [/portfolio-wrapper]

    Now it shows on the homepage like I want to with the Featured Images for each Portfolio post, but when I click on the link to each image, I get a 404 error. So something is not linking correctly. I think hover over one of the images and I get this URL:

    http://thewhiskybar.com/great-environment/

    Which is fine, but it send me to a 404 error page. I then go to where I made the portfolio through the WordPress Backend. I hover over and get the view link and I get this:

    http://thewhiskybar.com/portfolio/great-environment/

    But when I visit the link again, I get a 404 error. So what could the problem be? I have reset my permalinks and I do have a page that still works. This seems to be a problem with the Portfolio pages themselves. Please help ASAP.

    Thanks

    So you know, I’m editing the site with the old website still live. I had to edit the Hosts file with the IP of my server so I can view/edit/put together this website. If you would like to login to see what the problem is then let me know and I can give you IP so you can edit the Hosts file as well.

    • This topic was modified 3 years, 6 months ago by  DepecheCode.
    Post count: 2054
    Rai
    June 21, 2014 at 2:00 am #495

    Hi everlonglp3,

    Portfolio single post permalink structure has parent which is it’s portfolio page template. In your case, it’s seem there were permalink conflict. Please try re-save or update your portfolio page template (go edit but without touching anything except update button).
    It’s should be great if we can view the demo or even check the WP-Admin.

    Thank you

    • This reply was modified 3 years, 6 months ago by  Rai.
    Post count: 2054
    Rai
    June 21, 2014 at 9:56 am #506

    Hi everlonglp3,

    How can I view your development server? So I can check your problem and get the solution.

    Thank you

    Post count: 8
    smartconcepts
    July 7, 2014 at 8:57 am #1214

    Hi,

    I am having the exact same issue. Can you please advise how this was resolved.

    Thank you.

    Post count: 2485
    Jegbagus
    July 7, 2014 at 1:15 pm #1225

    hi smartconcepts, may i know detail of your problem?
    also as Rai said, have you check on your portfolio that you already set your portfolio parent?

    Thank you

    Post count: 8
    smartconcepts
    July 7, 2014 at 3:03 pm #1235

    Portfolio parent is set to PORTFOLIO. You can check the website homepage at http://www.animazing.co.za to see the issue.

    Let me know if you need a login to the site, and where I can send it to.

    Thanks

    Post count: 2054
    Rai
    July 8, 2014 at 6:07 am #1266

    Hi smartconcepts,

    Please try re-save or update your portfolio page template (portfolio parent). It will refresh the permalink structure for portfolio.

    If you still had that problem, can you give us access to your backend and we will check it directly. You can drop us email for the login credentials via Profile Page.

    Thank you

    Rai

    Post count: 8
    smartconcepts
    July 8, 2014 at 9:26 am #1275

    I have done all what you suggested, plus I deleted the portfolio page, created a new one and renamed it to Video Portfolio. I then changed the individual posts to link to the correct parent. I also checked the DB integrity with CPanel tools, and did a DB repair for good measure. Nothing has worked. Homepage still reflects the wrong links.

    I urgently need this issue sorted out as the site must be complete by tomorrow.

    Unfortunately, however nice this template looks, it really SUCKS to work with, and until such time that you sort out the functionality bugs and get VC integrated, I will continue to hate every minute of working with it.

    Furthermore, the Profile Page link that you posted goes to 404. How ironic.

    I look forward to your further assistance.

    Post count: 3
    ilcaneceleste
    July 8, 2014 at 10:45 am #1281

    Hi everybody,

    I have the same problem. Scroll and see Featured Work section.

    http://hellomum.biz/alberto/

    Help me,
    Thanks!!

    Post count: 2485
    Jegbagus
    July 8, 2014 at 10:47 am #1282

    hi smartconcepts, we actually almost finish page builder to replace section builder we having right now. our estimate we can release it on next friday.

    also for your portfolio problem, please send me email from this url, also don’t forget to create us login credential that able to modify post and portoflio : http://themeforest.net/user/jegtheme

    Thank you

    Post count: 2485
    Jegbagus
    July 8, 2014 at 10:51 am #1283

    hi smartconcepts, ilcaneceleste.
    you can try this easy trick,

    first trick, go to your portfolio list page. and save those portfolio.
    most of time the problem is because permalink structure that not yet get refreshed.

    or second trick, visit permalink structure on settings > permalinks. and simply click save to rebuild permalink.

    if both of trick not working, please let us know. we may need to check right into your admin panel to see if something wrong with it.

    Thank you

    Post count: 2485
    Jegbagus
    July 8, 2014 at 11:16 am #1285

    also one more trick, try to change your permalink setting to day & name. most of time combination with trick above will fix the problem.

    Thank you

    Post count: 8
    smartconcepts
    July 8, 2014 at 3:18 pm #1302

    HI,

    None of what you have suggested has worked.

    I have sent user credentials to the email address provided.

    Please fix this issue.

    Post count: 8
    smartconcepts
    July 9, 2014 at 9:26 am #1340

    Hi Guys,

    Any news on this issue? I urgently need a solution for this, and will greatly appreciated the assistance.

    Thanks in advance for the great support, and fast responses.

    Post count: 2485
    Jegbagus
    July 9, 2014 at 3:32 pm #1367

    hi smartconcepts, i fix this problem on email.
    i do this :

    also one more trick, try to change your permalink setting to day & name. most of time combination with trick above will fix the problem.

    Thank you

You must be logged in to reply to this topic.