Close

Account

Documentation

Forum

Menu

Plugin conflict / JS problem

  • Post count: 3
    Koenigsstein
    October 9, 2018 at 6:54 am #37979

    Hi, we are using the Simple:Press Plugin for a forum on our website. When the JNews theme is active, the controls in the Plugin settings do not react. I have copied the error message from the dev console below. The problem does not occur if I activate another theme, so the conflict seems to be with JNews. Hope you can help. Thanks.

    Uncaught Error: selector option must be specified when initializing tooltip on the window.document object!
    at c.init (bootstrap.min.js:6)
    at new c (bootstrap.min.js:6)
    at HTMLDocument.<anonymous> (bootstrap.min.js:6)
    at Function.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2)
    at a.fn.init.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2)
    at a.fn.init.b [as tooltip] (bootstrap.min.js:6)
    at HTMLDocument.<anonymous> (spa-admin-footer.js?ver=4.9.8:1)
    at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2)
    at Function.ready (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2)
    c.init @ bootstrap.min.js:6
    c @ bootstrap.min.js:6
    (anonymous) @ bootstrap.min.js:6
    each @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2
    each @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2
    b @ bootstrap.min.js:6
    (anonymous) @ spa-admin-footer.js?ver=4.9.8:1
    i @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2
    fireWith @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2
    ready @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2
    K @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-but&load[]=ton,jquery-ui-position,jquery-ui-dialog,utils&ver=4.9.8:2

    Post count: 1057
    Ferdy
    October 9, 2018 at 4:39 pm #38013

    Hi Koenigsstein,

    It seems we need to do further investigation on your website. Can you please provide us with login access to your website? You can send it here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 3
    Koenigsstein
    October 10, 2018 at 12:19 am #38029
    This reply has been marked as private.
    Post count: 1057
    Ferdy
    October 10, 2018 at 11:19 am #38052

    Hi Koenigsstein,

    Can you provide me with a URL with an error code? in this case, we did not find a page with an error code.

    Thank you

    Post count: 3
    Koenigsstein
    October 11, 2018 at 12:04 pm #38093

    Hi, when you go into the dashboard and then to “Forum”, you will see that the buttons and links in the Menu do not react. The error code is then shown in the Browser’s developer kit.

    Post count: 1057
    Ferdy
    October 11, 2018 at 1:47 pm #38098

    Hi Koenigsstein,

    Regarding this issue, I don’t have a good solution to this issue. have you tried to contact the plugin author regarding this issue? also at the moment, we don’t provide full support for the third-party plugin. you can check out our support policy (Support policy). but we will try to help our customer as long as we can.

    Thank you

    Post count: 1057
    Ferdy
    October 11, 2018 at 2:02 pm #38099

    Hi Koenigsstein,

    I have researched about your issue and I found this article that tooltips simple press plugin is conflict with bootstrap so you need to disable one or the other. Please check the article above.

    -The Topic
    https://simple-press.com/support-forum/pre-membership-queries/possible-but-with-bootstrap-tooltip-integration/#p160389

    -The solution
    https://simple-press.com/support-forum/pre-membership-queries/loading-white-screen-when-hovering-link/#p150647

    Thank you

    Post count: 3
    Koenigsstein
    October 12, 2018 at 7:31 am #38127

    Thanks, unfortunately disabling tooltips didn’t work. Is it possible to disable bootstrap in the theme?

    Post count: 11150
    Adek
    October 12, 2018 at 2:42 pm #38163

    Hi Koenigsstein,

    To disable tooltips js from the theme you can add this code below to the functions.php file:

    Thank you

You must be logged in to reply to this topic.