Close

Account

Documentation

Forum

Menu

PHP Warning after update in error log

  • Post count: 77
    tripledm
    September 11, 2018 at 4:21 pm #36543

    PHP Warning: Invalid argument supplied for foreach() in /xxxxxxx/wp-content/themes/jnews/class/ContentTag.php on line 47

    I have this error consistently coming up on the server error logs after the update.

    Please help!

    Post count: 11196
    Adek
    September 11, 2018 at 4:48 pm #36557

    Hi tripledm,

    Can you send me the URL and the content of the post that shows that error? I will try to replicate it on my side.

    Thank you

    Post count: 77
    tripledm
    September 11, 2018 at 4:54 pm #36561

    Hello, I will post in a private reply a few entries they run consistently it’s not limited to one post it affects all.

    Post count: 77
    tripledm
    September 11, 2018 at 4:55 pm #36562
    This reply has been marked as private.
    Post count: 11196
    Adek
    September 12, 2018 at 10:32 am #36611

    Hi tripledm,

    Regarding this issue, it seems I will need to do further investigation on your website. In this case, can you please enable WP_DEBUG on your website, in order to show the error message on the frontend. You can check this article about enable WP_DEBUG https://codex.wordpress.org/Debugging_in_WordPress

    Thank you

    Post count: 77
    tripledm
    September 14, 2018 at 6:58 pm #36794

    Hello,

    It’s impossible for me as it’s a live media / publishing website but I am trying to work with the host as well to see if we can resolve/find the cause.

    We have a staging environment and I will try replicated the errors there and if I don’t find the errors I will send you the login details/access for staging and enable debug.

    Post count: 11196
    Adek
    September 17, 2018 at 11:21 am #36853

    Hi tripledm,

    Yes sure, for a live website it would be better if you can create a staging environment for development purpose. Let me know if you have need a help in there.

    Thank you

    Post count: 1
    paolocode
    September 25, 2018 at 12:15 am #37305

    Hi, i have the same problem.. i can’t load Customizer on front-end , how i can fix it ?
    Thanks, Best Regards

    Post count: 11196
    Adek
    September 25, 2018 at 11:00 am #37331

    Hi paolocode,

    Can you provide me your site URL for further checking on my side?

    Thank you

    Post count: 8
    nelorca
    November 17, 2018 at 12:46 pm #39447

    I have the same issue:

    Após pedido do senador Otto Alencar, deputado Alex da Piatã começa reunir informações para possível CPI da Coelba

    Warning: Invalid argument supplied for foreach() in /home/ineosite/calilanoticias.com/wp-content/themes/jnews/class/ContentTag.php on line 47

    Warning: Invalid argument supplied for foreach() in /home/ineosite/calilanoticias.com/wp-content/themes/jnews/class/ContentTag.php on line 29

    thanks

    Post count: 77
    tripledm
    November 17, 2018 at 2:41 pm #39448

    I have that on 4 installs of the theme all with ContentTag.php on line 47 errors constantly coming up all day. It’s not breaking anything but it’s not great either so would be great if this gets resolved.

    Post count: 1201
    Ferdy
    November 19, 2018 at 10:57 am #39465

    Hi tripledm, paolocode and nelorca,

    regarding this issue, please go to wp-content/themes/jnews/class/ and then replace ContentTag.php file with this file (https://www.dropbox.com/s/4cwfd5ihw6e0io4/ContentTag.php?dl=0) . Let us know if you have further question.

    Thank you

    Post count: 77
    tripledm
    November 19, 2018 at 4:12 pm #39485

    Thank you Ferdy!

    I have updated all the sites with jnews and I will monitor and report back tomorrow so that it has some time to run to see if errors are gone.

    Post count: 1201
    Ferdy
    November 19, 2018 at 5:23 pm #39488

    Your welcome tripledm. let us know if you have further question.

    Thank you

    Post count: 77
    tripledm
    November 21, 2018 at 9:41 pm #39559

    Hello, I have a new set of PHP errors so the tag one has been resolved but these are left:

    [Tue Nov 20 01:02:06.252881 2018] [php7:error] [pid 21362] [IP] PHP Fatal error: Uncaught Error: Call to undefined function get_header() in [path]/wp-includes/theme-compat/embed.php:13\nStack trace:\n#0 {main}\n thrown in [path]/wp-includes/theme-compat/embed.php on line 13, referer: [URL]/wp-includes/theme-compat/embed.php

    [Tue Nov 20 01:06:34.298080 2018] [php7:error] [pid 21415] [IP] PHP Fatal error: Uncaught Error: Call to undefined function is_robots() in [path]/wp-includes/template-loader.php:28\nStack trace:\n#0 {main}\n thrown in [path]/wp-includes/template-loader.php on line 28, referer: //

    [Tue Nov 20 01:12:27.285122 2018] [php7:error] [pid 21510] [IP] PHP Fatal error: Uncaught Error: Class ‘JNews\\Archive\\IndexArchive’ not found in [path]/wp-content/themes/jnews/index.php:2\nStack trace:\n#0 {main}\n thrown in [path]/wp-content/themes/jnews/index.php on line 2

    [Tue Nov 20 01:12:28.071636 2018] [autoindex:error] [pid 21520] [IP] AH01276: Cannot serve directory [path]/wp-includes/css/: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xhtml,index.htm) found, and server-generated directory index forbidden by Options directive

You must be logged in to reply to this topic.