Close

Account

Documentation

Forum

Menu

Nofollow Sharing & Instagram links

  • Post count: 49
    promicabana
    March 8, 2018 at 2:07 am #29358

    Hi,

    how can I add the “nofollow” attribute to the sharing buttons, social profiles and Instagram images in the Footer?

    Thank you!

    Post count: 2684
    Rai
    March 8, 2018 at 10:24 am #29381

    Hi,

    I guess that is unnecessary, as far as I know, adding “nofollow” to your social media link will not affect your website PR. But, if you insist to do it, you need to customize theme code for that kind of changes.

    Thank you

    Post count: 49
    promicabana
    March 8, 2018 at 7:32 pm #29387

    Hi,

    I know, that I need to alter the theme code. But how and where?

    It’s enough for me to “nofollow” the sharing buttons and the instagram images.

    Thanks for your help!

    Post count: 2684
    Rai
    March 9, 2018 at 10:40 am #29417

    Hi,

    You need to change it in the plugin itself for both Social Share and Instagram feed.
    1) For social share, it is located at : wp-content/plugins/jnews-social-share/class-share-bar.php
    Go to line:527 and replace with this code:

    For Instagram feed, edit file located at : wp-content/plugins/jnews-instagram/class.jnews-instagram.php
    Update code on line:108 with this code:

    Thank you

    Post count: 8
    hiddenchar
    September 12, 2018 at 2:14 am #36596

    Hi Rai,

    I followed your tutorial for setting the social share links to nofollow, but it seems that only the secondary share buttons are affected. The primary buttons are still dofollow, which will unnecessarily pass valuable linkjuice to social networks. So how do I set the primary button-links to nofollow?

    With the JNews 3.0 update, there was also an update for the social share plugin, which overwrote my code. Is there a possibility to make the nofollow-code update-proof, that it can’t be overwritten (like using a child theme)?
    Otherwise I would appreciate it a lot, if you please could set the links to nofollow for the next plugin update.

    Thank you in advance
    Dennis

    https://ibb.co/e7wPc9

    • This reply was modified 1 month, 1 week ago by  hiddenchar.
    Post count: 10705
    Adek
    September 13, 2018 at 9:50 am #36679

    Hi hiddenchar,

    I’m not quite sure yet because you need to modify the plugin file. In this case, i’m not sure yet what the best solution for this case. I will consider adding nofollow to the link attribute.

    About the primary button, can you tell me more detail which button that you mean? I’m not sure yet.

    Thank you

    Post count: 8
    hiddenchar
    September 14, 2018 at 3:53 am #36740

    Hi Adek,

    the social share buttons are grouped into two groups: primary or “main share networks” and “secondary share networks”.
    You can customize both groups in customizer (please see link below):
    https://image.ibb.co/kn3ys9/cusomizer_social_share.jpg

    The main network share-buttons are always visible, the secondary buttons will appear, when clicking the arrow on the right (please see link below)
    https://image.ibb.co/hxcSKp/share_buttons.jpg

    With Rais code (see above #29417) the secondary network share-button-links (in my case Email and Twitter) are set to nofollow, but it seems, that the main network share-button-links (in my case facebook, pinterest and whatsapp) still remain dofollow.

    I would like to have all share-button-links (main and secondary) are set to nofollow.

    In the following screenshot, you can see, that only the secondary share-network-button-links are nofollow, because my nofollow-highlighter-plugin painted them red.
    The source-code shows, that only the secondary network-share-buttons have the “nofollow” tag.
    https://image.ibb.co/b2kHx9/nofollow.jpg

    I hope you understand my problem 🙂
    Thank you so much in advance
    Regards, Dennis

    Post count: 10705
    Adek
    September 14, 2018 at 12:31 pm #36767

    Hi Dennis,

    Thanks for your detail explanation.

    Please try to go edit this file wordpress/jnews-social-share/class.jnews-share-bar.php then jump into line 529. Update that line code with this one below:

    Thank you

    Post count: 6
    Fernando
    September 14, 2018 at 5:00 pm #36785

    I have also added the same in that line of code and the social links keep appearing in dofollow.

    It would be important that this be resolved as soon as possible because the one who knows a little SEO will know that this would not be correct.

    Post count: 6
    Fernando
    September 14, 2018 at 5:19 pm #36786

    https://prnt.sc/kual2u

    Profile links do not show nofollow attributes either

    • This reply was modified 1 month ago by  Fernando.
    Post count: 10705
    Adek
    September 17, 2018 at 11:06 am #36849

    Hi Fernando,

    I’m not quite sure yet, the code above just works fine on my side. I will need to do further investigation on your website. Can you provide me FTP access to your server? I will need to check some themes file. You can send the information here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 8
    hiddenchar
    September 20, 2018 at 12:58 am #37037

    Hi,

    I have the same result as Fernando – the primary Links are still dofollow. It seems that the code only affects the secondary share button links. I wrote “test” at the end of line 529 for testing purposes. It appears only on second share button links:

    https://image.ibb.co/drh1sK/test.jpg

    Regards, Dennis

    • This reply was modified 4 weeks, 1 day ago by  hiddenchar.
    Post count: 10705
    Adek
    September 20, 2018 at 11:30 am #37074

    Hi Dennis,

    I will need to do further investigation on your website. Can you provide me FTP access to your server? I will need to check some themes file. You can send the information here and don’t forget to check Set as private reply option below.

    Thank you

You must be logged in to reply to this topic.