Close

Account

Documentation

Forum

Menu

"No Content Available" on category page

  • Post count: 2
    RealWeb11
    March 21, 2018 at 9:59 pm #29805

    Hi!
    I bought and installed your JNews theme and imported the demo content. Then I added a new category “Test” and created a new post “Test” and added it to the category “Test”. If I now go to the category view, then in the hero block it shows my post “Test”. But in the content block it says “No Content Available”. You can see it here – https://pollumeheteataja.ee/blog/category/test/

    If I view some imported demo category, then it seems to be OK, the demo news are all there. For example – https://pollumeheteataja.ee/blog/category/entertainment/ . But if I add my own post to this category then it doesn’t show up in the content block. And also if I add some demo news to my “Test” category, then they do not show up in the “Test” category page.

    Can you tell me, what is wrong? And what should I do?

    Thanks!

    Post count: 10865
    Adek
    March 22, 2018 at 10:23 am #29822

    Hi RealWeb11,

    Regarding this issue, on the category page will try to fill out the hero block at first and if there’s no remaining post, then it will go into the content block at the bottom. In this case, if there’s no remaining post for the content block, it will show no content available. This behavior will prevent duplicated post on hero block and content block.

    Let me know if you have further question.

    Thank you

    Post count: 2
    RealWeb11
    March 22, 2018 at 3:45 pm #29834

    Thank you! Now I understand.

    Post count: 10865
    Adek
    March 22, 2018 at 5:07 pm #29847

    You’re welcome RealWeb11,

    Let me know if you need something else in there.

    Thank you

You must be logged in to reply to this topic.