Close

Account

Documentation

Forum

Menu

Is it unable to make a hyper link in "Footer text"?

  • Post count: 14
    Green
    February 18, 2016 at 8:21 am #18600

    Hi,

    I want to make a hyper link in “General”-“Footer Setting”-“Footer text”, like
    © Daisy YOHOHO 2016. Designed by <a href="http://facekungfu.com">FaceKungFu Studio</a>

    But the hyper link code doesn’t work. I thought “Footer text” is just like another widget…
    How to make it work? Is there any method?

    Thanks.
    Green

    Post count: 1844
    Rai
    February 19, 2016 at 3:49 am #18614

    Hi Green,

    It is possible by little tweaks, please update file located at: falive-themes/footer.php and scroll down to line:39 you should find this code:
    <span><?php echo esc_html( $footer_text );?></span>

    Update with this code:
    <span><?php echo wp_kses_post( $footer_text );?></span>

    Thank you

    Post count: 14
    Green
    February 19, 2016 at 6:08 am #18616

    Hi,

    Thanks for replying soon and helpful, the hyper link works now!
    But there’s some other problem:
    160219 Customize-Footer Text:Text-with-hyper-link-can't-be-coloured

    As the image, normal text can be coloured by Customize-Footer Text, but text wish hyper link can not.
    Is there any control panel in Falive Dashboard, or should I add Custom CSS in Advanced Setting?

    The element:

    What codes should I type and add in Custom CSS? Will it support customization like effect and color of hover, active and underline?
    Or I can add codes right in Falive Dashboard-Footer Setting-Footer text?

    Thanks,
    Green

    Post count: 1844
    Rai
    February 21, 2016 at 2:13 am #18650

    Hi,

    Your image link seems broken. It need custom CSS for styling that link: Falive Dashboard > Advanced Settings > Custom CSS. Try this to change link color:

    Thank you

    Post count: 14
    Green
    February 23, 2016 at 5:26 am #18721

    Hi,

    It works!

    Thanks.
    Green

    Post count: 1844
    Rai
    February 24, 2016 at 6:01 am #18741

    you’re welcome 🙂

You must be logged in to reply to this topic.