Close

Account

Documentation

Forum

Menu

HTTP 500 Error after migrating a website with Jnews theme activated

  • Post count: 3
    AZNeoMedia
    September 8, 2018 at 12:21 am #36295

    I’m trying to migrate a website that has jnews theme activated on a sever. And when I activate the theme it always returns HTTP 500 ERROR. What should I do?

    Post count: 3
    AZNeoMedia
    September 8, 2018 at 12:31 am #36299

    Is the theme compatible with php 5.6?

    Post count: 71
    TheIndiaPost
    September 8, 2018 at 2:30 pm #36331

    I am also facing this problem, My host says it is theme fault. If they cant solve this, than we have to ask refund. It is slow also.

    • This reply was modified 2 weeks, 3 days ago by  TheIndiaPost.
    Post count: 10489
    Adek
    September 10, 2018 at 2:54 pm #36394

    Hi AZNeoMedia,

    JNews is compatible with PHP 5.6. In this case, please try to enable WP_DEBUG to show the error message that related to error 500. Please check this article regarding enable WP_DEBUG https://codex.wordpress.org/Debugging_in_WordPress. Then please send me the error message that shows on your website.

    @theindiapost,

    I’ve been answering your question on this thread http://support.jegtheme.com/forums/topic/how-to-use-demo-theme-2/#post-36385, kindly you can check it out.

    Thank you

    Post count: 3
    AZNeoMedia
    September 10, 2018 at 9:11 pm #36455

    The only log that it shows it’s:
    [10-Sep-2018 13:04:41 UTC] PHP Notice: Use of undefined constant REQUEST_URI – assumed ‘REQUEST_URI’ in […]/themes/jnews/functions.php on line 68

    And after changing it to correct ‘REQUEST_URI’ on that line. It doesn’t log any other errors only displaying a blank page.

    Post count: 3
    AZNeoMedia
    September 10, 2018 at 10:26 pm #36459

    I finally managed to fix the issue. It was coming from a php module error on my Apache server.
    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20131226/curl.so’
    So i fixed it by installing the php-5.6-curl package again.
    If someone get’s stuck with this i suggest they look at the apache error.log file. To see if they have any PHP Warnings.
    Thanks for the help guys.

    Post count: 10489
    Adek
    September 11, 2018 at 2:32 pm #36522

    Hi AZNeoMedia,

    Glad to hear if you’ve already able to solve the problem and thanks for your sharing, really appreciate it. Let us know if you need something else in there.

    Thank you

You must be logged in to reply to this topic.