Close

Account

Documentation

Forum

Menu

How do I speed the website load. Very slow

  • Post count: 94
    dmitri1999
    February 24, 2015 at 6:51 am #9579

    Hi,
    With the landing slider and Contact 7 form on 1 page it’s 80 processes. Without them, it’s over 50. Website is getting extremely low scores on all the speed testing sites. What can be done to speed this up? I installed w3 total cache plugin and so far there weren’t any benefits from it.

    Post count: 6417
    Adek
    February 27, 2015 at 11:17 am #9680

    Hi dmitri1999,

    Please try to disable all plugins except the required plugin that come with these theme. Also the page speed on backend and frontend is depend on many factors, such as internet speed, server speed, scripts loaded, Images optimize, additional plugin and etc.

    Thank you

    Post count: 94
    dmitri1999
    March 15, 2015 at 8:46 pm #9986

    I tried and it barely made things better. There are a ton of processes and css that slow things down.
    I turned off all the fancy stuff.

    I tested your demo sites on various testing sites and they are also very slow. You get 49/100 on Google Pagespeed which is pretty bad, as you know.
    My site gets a score of 19, which is beyond bad for a pretty simple home page.

    What can be done to speed things up? Some people say certain processes can be joined together which helps with the page load. If that is true, how would I go about doing it?

    Post count: 6417
    Adek
    March 18, 2015 at 3:52 am #10044

    It’s because on our demo have a lot of content, especially on the landing page. It’s very long page, so it will take more time to load all of our content. I’m sorry, but i’m not quite sure about that. Actually on our demo page isn’t using the latest version of themes yet. On the latest version of themes we make sure, we’ve been make the speed on the backend and frontend more faster.

    Thank you

    Post count: 94
    dmitri1999
    March 18, 2015 at 6:02 am #10066

    Any speed improvements are always great, thanks!
    I’ll try to play around with caching plugins. hopefully that can help a bit.

You must be logged in to reply to this topic.