Close

Account

Documentation

Forum

Menu

gtmetrix bad score

  • Post count: 39
    nasimnazanin88
    October 11, 2018 at 5:58 pm #38109

    Hi,
    I checked my website built with Jnews theme in Gtmetrix and I get a bad score because if the defer parsing of Javascript. How can I solve that cause I think this is due to the theme.
    I have other websites built with other themes and they don’t have this issue.

    https://imgur.com/a/GaOYKpl

    Post count: 23
    Bloomland
    October 12, 2018 at 9:07 am #38132

    Comparing to mine, that’s a very good score.

    Post count: 11150
    Adek
    October 12, 2018 at 2:27 pm #38156

    Hi nasimnazanin88,

    Can you send me your site URL for further checking on my side? I will check it directly.

    Thank you

    Post count: 39
    nasimnazanin88
    October 12, 2018 at 9:44 pm #38182
    This reply has been marked as private.
    Post count: 1057
    Ferdy
    October 15, 2018 at 2:32 pm #38227

    Hi nasimnazanin88,

    Please try to enable JNews Speed plugin or install autoptimze plugin and then check again in Gtmetrix.

    Thank you

    Post count: 39
    nasimnazanin88
    October 15, 2018 at 4:02 pm #38235

    Hi,
    I used the JNews Speed plugin once and the resutl was my images didn’t load anymore.
    Maybe it’s better to use this code:

    function defer_parsing_of_js ( $url ) {
    if ( FALSE === strpos( $url, ‘.js’ ) ) return $url;
    if ( strpos( $url, ‘jquery.js’ ) ) return $url;
    return “$url’ defer “;
    }
    add_filter( ‘clean_url’, ‘defer_parsing_of_js’, 11, 1 );

    Post count: 1057
    Ferdy
    October 16, 2018 at 11:17 am #38261

    Hi nasimnazanin88,

    Please try to use normal image load and try to enable JNews Speed Plugin again. then check it on gtmetrix. You can find Image load Configuration on Customizer > JNews : Image & Gallery Option > Image Load & Generator Setting

    Thank you

    Post count: 39
    nasimnazanin88
    October 16, 2018 at 5:38 pm #38280

    I made what you said. The result:

    – the home page slider didn’t load
    – all the custom fonts disappeared
    – the home page sidebar get in total disorder.

    Post count: 1057
    Ferdy
    October 18, 2018 at 9:47 am #38312

    Hi nasimnazanin88,

    1. I’ve been checking your website, the home page slider is working fine on my side. Please check this screenshot.
    2&3 Can you explain more to me and give me an example?

    Thank you

    Post count: 39
    nasimnazanin88
    October 20, 2018 at 4:05 am #38396

    the slider is working cause I removed the Jnews speed plugin and I can’t let it be installing with such a big error. But as I explained, after installing the plugin all the slide show images disappears. But I think I will fix the issue with another plugin which fix the defer parsing….

    Post count: 11150
    Adek
    October 22, 2018 at 12:00 pm #38428

    Hi nasimnazanin88,

    Regarding this issue, maybe you need to do some setup for JNews Speed plugin in there. If you want to try use JNews Speed plugin again, i will help you to setup it. Let me know if you need further help in there.

    Thank you

    Post count: 39
    nasimnazanin88
    October 26, 2018 at 3:49 am #38659

    ok please tell me the best set up for the plugin cause right now when I install it my custom fonts and pic and all the home page get distorted.
    I also used other cache plugins like the w3 total cache for the defer parsing but I get the same bad results.

    Post count: 11150
    Adek
    October 26, 2018 at 4:19 pm #38685

    Hi nasimnazanin88,

    Please try to enable Load jQuery Early option on the Customize > JNews : Speed Option > Advanced Option > Load jQuery Early. If you still get the problem, please provide me login access to your website. I will need to do further investigation on your website. You can send it here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 39
    nasimnazanin88
    October 27, 2018 at 4:21 pm #38717
    This reply has been marked as private.
    Post count: 11150
    Adek
    October 29, 2018 at 5:33 pm #38773

    Hi nasimnazanin88,

    I’ve been checking your website previously and i notice you’re using WPCF plugin. Also, that plugin has the concat and minify and defer asset feature same as JNews Speed plugin. It may conflict in there. In this case, you can keep disable the concat and minify and defer asset feature from JNews Speed plugin and use the one from WPCF. Actually, for cache plugin, JNews support Super Cache plugin. For another plugin, you may need to do some setup to get the best result. Let me know if you have further question.

    Thank you

You must be logged in to reply to this topic.