Close

Account

Documentation

Forum

Menu

Google Fonts in AMP

  • Post count: 48
    silverheim
    September 5, 2018 at 8:41 pm #36166

    Hello. Due to GDPR, google fonts must be disabled also in AMP version. Will you disable it from amp version?

    Also, any new about the update?

    Post count: 11069
    Adek
    September 6, 2018 at 10:47 am #36184

    Hi silverheim,

    We’ve been providing an option to disable Google Font on the AMP or non AMP page. You can find the option on the Customizer > JNews Additional Option > GDPR Compliance > Google Font Settings.

    Thank you

    Post count: 48
    silverheim
    September 6, 2018 at 11:37 am #36190

    Right. Thanks. Good to know this. So, enabling that option will disable google fonts both for amp and non amp pages. Right?

    About the v3 update. Any new? You said for this week but nothing yet 🙁

    Post count: 11069
    Adek
    September 6, 2018 at 1:37 pm #36194

    Yes, you’re right.

    About JNews V3, at the moment we still making the new landing page and new item description. Yes, we have a plan to release it on this week or next week at least. Please be patient for this moment and thanks for your attention. Let me know if you have further question.

    Regards

    Post count: 48
    silverheim
    September 6, 2018 at 9:40 pm #36203

    Hello. I enabled the Google Fonts Settings but it still appearing in amp version. Please look bellow:

    <script type=’text/javascript’ src=’https://cdn.ampproject.org/v0.js’ async></script>
    <script type=’text/javascript’ src=’https://cdn.ampproject.org/v0/amp-ad-latest.js’ async custom-element=”amp-ad”></script>
    <script type=’text/javascript’ src=’https://cdn.ampproject.org/v0/amp-analytics-0.1.js’ async custom-element=”amp-analytics”></script>
    <link rel=”stylesheet” href=”https://fonts.googleapis.com/css?family=Merriweather:400,400italic,700,700italic”><style amp-boilerplate>body{-webkit-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-moz-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-ms-animation:-amp-start 8s steps(1,end) 0s 1 normal both;animation:-amp-start 8s steps(1,end) 0s 1 normal both}@-webkit-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-moz-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-ms-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-o-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}</style><noscript><style amp-boilerplate>body{-webkit-animation:none;-moz-animation:none;-ms-animation:none;animation:none}</style></noscript> <script type=”application/ld+json”>{“@context”:”http:\/\/schema.org”,”publisher”:{“@type”:”Organization”,”name”:”Krump”,”logo”:{“@type”:”ImageObject”,”url”:

    Post count: 11069
    Adek
    September 7, 2018 at 10:26 am #36221

    Hi silverheim,

    I do not quite understand what you mean above. If you enable the Google Font Setting, the Google font will be loaded on AMP page. Can you explain more detail your problem?

    Thank you

    Post count: 48
    silverheim
    September 7, 2018 at 10:27 am #36222

    Hello. What i mean: i have disabled Google fonts in gdpr options but it still appearing in amp posts versions. Why?

    Post count: 11069
    Adek
    September 7, 2018 at 11:36 am #36234

    Hi silverheim,

    In this case, i will need to do further investigation on your website. Can you provide me login access to your website? You can send it here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 48
    silverheim
    September 7, 2018 at 11:54 am #36237

    Hello Adek. The same issue you can see in your demo: https://jnews.io/default/2017/01/18/retirees-it-may-be-time-to-get-your-head-out-of-the-sand/amp/

    Please take a look. Its the same thing.

    Post count: 11069
    Adek
    September 7, 2018 at 1:18 pm #36244

    Hi silverheim,

    It’s because at the moment we don’t disable Google Font on our demo.

    If you still getting the problem please try to update this file wp-content/themes/jnews-amp/class.jnews-amp.php with this one here https://pastebin.com/9CawriNJ

    Thank you

You must be logged in to reply to this topic.