Close

Account

Documentation

Forum

Menu

Getting Warning For navigation-top.php

  • Post count: 9
    DepecheCode
    June 14, 2014 at 12:03 am #284

    Hey guys,

    I need a little help. Just installed the theme and I’m getting this following warning at the top:

    Warning: getimagesize(http://thewhiskybar.com/wp-content/themes/jkreativ-themes/public/img/logo.png) [function.getimagesize]: failed to open stream: HTTP request failed! HTTP/1.0 404 Not Found in /home/thewhisk/public_html/wp-content/themes/jkreativ-themes/template/navigation-top.php on line 43

    Here is the PHP file and the coding it’s referring to so you can make sure nothing is missing:

    <?php
    global $woocommerce;
    $navobj = jeg_get_navigation_setup();
    ?>

    <div class=”navigation-flag”></div>
    <div class=”topnavigation”>

    <?php if($navobj[‘navtoptwoline’]) { ?>
    <div class=”twolinetop”>
    <div class=”<?php echo ( $navobj[‘navtopcenter’] ) ? “navigationcontainer” : “”; ?>”>
    <div class=”topnavmsg”> <?php echo get_theme_mod(‘jeg_top_sec_tagline’, ”); ?> </div>
    <div class=”topwrapperabove”>
    <?php
    jeg_get_template_part(‘template/navigation-top’, ‘social’);
    jeg_get_template_part(‘template/navigation-top’, ‘woo’);
    ?>
    </div>
    </div>
    </div>
    <?php } ?>

    <div class=”topwrapper <?php echo ( $navobj[‘navtopcenter’] ) ? “navigationcontainer” : “”; ?>”>
    <div class=”topwrapperbottom”>

    <?php
    $topnavlogo = get_theme_mod(‘jeg_top_nav_logo’, get_template_directory_uri() . ‘/public/img/logo.png’);
    if(ctype_digit($topnavlogo) || is_int($topnavlogo)) {
    $topnavlogo = wp_get_attachment_image_src($topnavlogo, “full”);
    $topnavlogo = $topnavlogo[0];
    }

    $topnavlogoretina = get_theme_mod(‘jeg_top_nav_logo_retina’, get_template_directory_uri() . ‘/public/img/logo.png’);
    if(ctype_digit($topnavlogoretina) || is_int($topnavlogoretina)) {
    $topnavlogoretina = wp_get_attachment_image_src($topnavlogoretina, “full”);
    $topnavlogoretina = $topnavlogoretina[0];
    }

    if(empty($topnavlogoretina)) {
    $topnavlogoretina = $topnavlogo;
    }

    $topnavlogoimagesize = getimagesize($topnavlogo);
    $topnavlogoimagesize = “width : {$topnavlogoimagesize[0]}px; height: {$topnavlogoimagesize[1]}px;”;
    ?>
    <div class=”logo” style=”padding-left: <?php echo get_theme_mod(‘jeg_top_nav_left_position’, 20); ?>px;”>
    “>
    px; <?php echo $topnavlogoimagesize; ?>” data-at2x=”<?php echo $topnavlogoretina; ?>” src=”<?php echo $topnavlogo; ?>” alt=”<?php bloginfo(‘name’); echo ” “; bloginfo(‘description’); ?>”/>

    </div>

    <?php
    if(!$navobj[‘navtoptwoline’]) {
    jeg_get_template_part(‘template/navigation-top’, ‘social’);
    jeg_get_template_part(‘template/navigation-top’, ‘woo’);
    }
    ?>

    <div class=”topnavigationsearch”>
    <i class=”fa fa-search”></i>

    <?php if($navobj[‘navpos’] === ‘transparent’) { ?>
    <div class=”abs-search”>
    <?php get_search_form(); ?>
    </div>
    <?php } ?>

    </div>
    <?php jeg_get_template_part(‘template/navigation-top’, ‘menu’); ?>

    <?php if($navobj[‘navpos’] === ‘top’) { ?>
    <div class=”topsearchwrapper”>
    <?php get_search_form(); ?>
    <div class=”closesearch”>
    <i class=”fa fa-times”></i>
    </div>
    </div>
    <?php } ?>

    </div>
    </div>

    </div>

    Post count: 2485
    Jegbagus
    June 14, 2014 at 7:17 am #286

    hi everlong, please try to override those code with this one : http://pastebin.com/RshhhKDv
    if you still have problem, please just let me know.

    Thank you

    Post count: 3
    luvtowrite
    June 14, 2014 at 3:29 pm #287

    I tried it, that didn’t work for me.

    Post count: 3
    luvtowrite
    June 14, 2014 at 3:53 pm #288

    Please tell me how a person puts a new post for support on this forum?

    Post count: 2058
    Rai
    June 15, 2014 at 7:09 am #289

    Hi luvtowrite,

    To create new thread first you pick what forum you would to post from Forum List in sidebar, and then scroll down to “Create New Topic in …” bellow topic lists.

    Regards,
    Rai

    Post count: 3
    MplsDigital
    June 15, 2014 at 6:27 pm #290

    I have a similar problem. This is the error I’m getting.
    – – – – – ERROR TEXT START – – – – –
    : getimagesize() []: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in on line : getimagesize(http://mplsdigital.com/wpdev/wp-content/themes/jkreativ-themes/public/img/logo.png) []: failed to open stream: no suitable wrapper could be found in on line

    Warningfunction.getimagesize/data/17/1/106/141/1595793/user/1719441/htdocs/wpdev/wp-content/themes/jkreativ-themes/template/navigation-side.php21

    Warningfunction.getimagesize/data/17/1/106/141/1595793/user/1719441/htdocs/wpdev/wp-content/themes/jkreativ-themes/template/navigation-side.php21
    WPDEV

    – – – – – ERROR TEXT END – – – – –

    So for me the nav isn’t working.
    Here’s where my development site is: http://www.mplsdigital.com/wpdev/

    Any ideas how to fix this? I’ve already tried using this code at pastebin
    http://pastebin.com/RshhhKDv

    That didn’t work or change anything.
    I’m running WordPress 3.9.1
    I have all the required plugins installed and activated.

    Any ideas? Thanks for your help!

    Post count: 3
    MplsDigital
    June 15, 2014 at 7:21 pm #291

    A few more notes: I’ve also already tried re-installing WordPress, and I’ve tried uploading the theme files manually via FTP (rather than the automatic upload of a zip). And it still gives me the error mentioned above.

    Post count: 2485
    Jegbagus
    June 15, 2014 at 10:38 pm #292

    hi MplsDigital, we already update themes to version 1.0.1.
    please re download and install new version of themes to fix this problem.
    if you still having problem, please let us know.

    Thank you 🙂

    Post count: 3
    MplsDigital
    June 16, 2014 at 3:01 am #298

    I downloaded the 1.0.1 version and that seems to have fixed the error I was getting. So the navigation looks like it’s working now. Thank you! 🙂

    Post count: 2485
    Jegbagus
    June 16, 2014 at 3:26 am #299

    you are welcome 🙂

You must be logged in to reply to this topic.