Close

Account

Documentation

Forum

Menu

Facebook Social Login not working on Jnews

  • Post count: 4
    LukeMcCabe1
    April 10, 2018 at 8:29 am #30323

    Hi there,

    I’m having trouble with the facebook social login on Jnews theme.

    Visit: https://mummytime.co/

    The app is setup correctly in facebook, its and the callback is correct.

    This is the problem:

    1. Hit the login button on site and click Facebook signup
    2. Facebook app pops up and asks for facebook user permissions
    3. Returns you to the site with a strange url fragment: https://mummytime.co/#_=_ and doesn’t log facebook user in.

    See screenshot here: https://mummytime.co/wp-content/uploads/2018/04/Screen-Shot-2018-04-09-at-11.19.34-pm.png

    It looks like a theme issue. Just wondering if you could let me know how I can fix this.

    I’m using Child theme of JNewsVersion: 1.2.2

    Thanks

    Post count: 9465
    Adek
    April 10, 2018 at 9:21 am #30329

    Hi LukeMcCabe1,

    Regarding this issue, please enable WP_DEBUG to check if there’s an error message that occurs when using Facebook login. You can follow the instruction on our documentation regarding WP_DEBUG here http://support.jegtheme.com/documentation/system-status/

    Thank you

    Post count: 4
    LukeMcCabe1
    April 11, 2018 at 7:25 am #30356

    Hi Adek,
    Have already tried the debug mode, unfortunately it doesn’t return any errors – it makes the login / register links at top right to load and the icon keeps showing as loading but no links. I think in debug mode the javascript files are probably blocked and the relevant widget/ plugin is not loaded correctly on the site. Could you please try and register on the site using your facebook account to see the problem: https://mummytime.co/

    Post count: 9465
    Adek
    April 11, 2018 at 9:34 am #30357

    Hi LukeMcCabe1,

    It seems i need to do further investigation directly on your website. Can you please provide me FTP access to your server? Also, may i know what Facebook API version that you use currently?

    You can send it here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 4
    LukeMcCabe1
    April 11, 2018 at 10:03 am #30360
    This reply has been marked as private.
    Post count: 4
    LukeMcCabe1
    April 12, 2018 at 7:41 am #30385
    This reply has been marked as private.
    Post count: 9465
    Adek
    April 12, 2018 at 10:21 am #30396

    Hi LukeMcCabe1,

    The FTP info above doesn’t work on my side. I’m using Filezilla, here’s my setup https://www.dropbox.com/s/22zjky9np590vb9/Screenshot%202018-04-12%2010.19.57.png?dl=0

    Anyway, please try to replace this folder wp-content/plugins/jnews-social-login/include/source/facebook-sdk-v5 with this one here https://www.dropbox.com/s/xnvh0q10mnsabuk/facebook-sdk-v5.zip?dl=0

    Thank you

    Post count: 4
    LukeMcCabe1
    April 12, 2018 at 11:58 am #30397

    Thanks Adek. This worked.

    Post count: 9465
    Adek
    April 13, 2018 at 9:21 am #30423

    Glad to hear that LukeMcCabe1 and please don’t forget to leave 5 stars rating for JNews 😀 it will help us much.

    Thank you

You must be logged in to reply to this topic.