Close

Account

Documentation

Forum

Menu

empty page in 2 of my 3 languages

  • Post count: 69
    cdaldoss
    April 1, 2015 at 11:05 am #10514

    Hi Dek,

    don’t know whats happening but now I got empty page in 2 of my 3 languages and I’m not able to get them back working as it was til yesterday.

    Spanish language is working properly: http://www.mybabyd.com/es/portfolio/
    Italian and english doesn’t have content, only the menu… http://www.mybabyd.com/it/portfolio/ and http://www.mybabyd.com/portfolio/

    How this happened?

    hope you can help,

    thanks and regards,
    Carlotta

    Post count: 6682
    Adek
    April 2, 2015 at 9:44 am #10541

    Hi Carlotta,

    It’s weird for me. May i know what you do previously with your portfolio page? If you’ve been change the permalink structure or install new plugin?

    Thank you

    Post count: 69
    cdaldoss
    April 2, 2015 at 11:25 am #10550

    Hi Dek,
    the only thing I did around the portfolio it was translate the name of the categories but I checked with one of them before to do with everyone and everything was working…

    Thinking about it I didn’t change it after when I finished… I had the names of them in spanish so I translate them in english and italian… nothing else… and the strange thing is that I also modify some of the spanish names but that page is working…

    Do you have any idea?

    thanks and regards
    CArlotta

    Post count: 6682
    Adek
    April 6, 2015 at 6:59 am #10589

    Hi Carlotta,

    Actually i’m not quite sure about this problem. Did you try to create a new portfolio list page? Please try to contact plugin author regarding this issue.

    Thank you

    Post count: 69
    cdaldoss
    April 6, 2015 at 9:42 am #10625

    Hi Dek,

    no I didn’t try… I’ll try now and let you know..
    you mean the WPML plugins authors do you?

    thanks

    Post count: 69
    cdaldoss
    April 12, 2015 at 11:33 pm #10769

    Hi Dek,
    just to let you know that I fix the problem redoing again all the portfolios I previously had.
    pretty boring and time consuming but it was the only way to get them visibles again.

    thanks and regards,
    Carlotta

    Post count: 69
    cdaldoss
    May 6, 2015 at 10:40 am #11429

    Hi Dek,

    I’m contacting you again about this matter us I had WPML support checking at it and they just find out now that is a compatible problem. I paste you down here the last answer I got where they say which is the problem and they suggest you how to fix it but you could find thefull support ticket conversation at this link: Full WPML support ticket

    ANSWER FROM WPML SUPPORT

    I suggest contacting with the theme author and ask them apply to our Go Global program: http://wpml.org/documentation/theme-compatibility/go-global-program/ .

    The theme author can announce anything but we can make sure and test with the themes that are listed under our lists only.

    Actually I can not find the reason and the way to give you a temporary workaround.

    This is really a compatible problem when it looks like in the register_post_type function, the theme author is using the parameter ‘rewrite’ without the value ‘portfolio’ – the same with post_type.

    (The file jkreativ-themes\admin\post_type.php), line 70

    1
    ‘rewrite’ => array(‘slug’ => ‘%portfolio_page%’,’with_front’=>true),
    This option should be ‘rewrite’ => true

    We wrote about this specific case at https://wpml.org/documentation/getting-started-guide/translating-page-slugs/ (in the bottom) and https://wpml.org/faq/how-to-translate-custom-types/

    Actually it’s not simple like editing a line because the theme author is using a lot of filters for this.

    —–

    I hope you could fix this matter soon as after I resolve it redoing all the portfolios I had it again and now it’s fixed with a redirection plugin to now have broken URL in the website.
    thanks nad regards
    Carlotta

    Post count: 6682
    Adek
    May 7, 2015 at 10:40 am #11487

    Hi Carlotta,

    Thanks for your information. I will inform it for our team.

    Thank you

    Post count: 69
    cdaldoss
    May 7, 2015 at 11:12 am #11494

    Hi Dek,

    thanks to you, I will wait to know when you have news about this matter as it’s causing problems with the translations and multi language .

    I copy here to you last message from the WPML support:

    Please update me when having any info.

    And if possible, ask the theme author to join our Go Global program, then he can work with our compatibility team directly. That’s much better rather than giving the support here. Because the supporters can just diagnose the problems.

    Thanks for your patience.

    KR,
    Carlotta

You must be logged in to reply to this topic.