Close

Account

Documentation

Forum

Menu

Classic Mode Editor Not Displaying Properly

  • Post count: 8
    RachelKHawkins
    April 3, 2018 at 11:15 pm #30151

    Hello,

    We are working on updating our theme on our staging server. It looks like the jkreativ plugin is interfering with our copy of WPBakery Page Builder. When editing a page, I cannot edit a page in Classic Mode, as displayed below.

    backend editor

    classic mode

    I deactivated all of our site plugins and reactivated them one by one. The jkreativ plugin was the only one to cause this issue. How can we go about resolving this issue?

    Thanks in advance for your help.

    Post count: 11196
    Adek
    April 5, 2018 at 10:49 am #30198

    Hi RachelKHawkins,

    Can you tell me what JKreativ version and WPBakery plugin that you use on your website?

    Thank you

    Post count: 8
    RachelKHawkins
    April 10, 2018 at 10:53 pm #30353

    Hello,

    We are running JKreativ version 2.4.4 and WPBakery Page Builder version 5.4.

    Cheers,

    Rachel Hawkins

    Post count: 8
    RachelKHawkins
    April 23, 2018 at 10:36 pm #31005

    Hi Adek,

    Checking in again since I haven’t heard from you or your team. Do you have an update for this issue?

    Cheers,

    Rachel Hawkins

    Post count: 2759
    Jegbagus
    May 1, 2018 at 11:46 am #31337

    hi RachelKHawkins,

    to fix this issue, you can go to jkreativ themes folder > asset > js > pagemetabox.js (on line 98)
    and change to

    Thank you

    Post count: 8
    RachelKHawkins
    May 3, 2018 at 12:39 am #31465

    Hello,

    Not only did this not fix the original issue, but it also broke the Yoast SEO plugin. Now the stoplight image takes up the whole page – see attached. Please advise further.

    yoast and classic editor screenshot

    Cheers,

    Rachel Hawkins

    Post count: 8
    RachelKHawkins
    May 3, 2018 at 12:42 am #31466

    Another note: I also had problems opening and editing the file through Filezilla. I kept getting an 800a1391 error.

    Post count: 11196
    Adek
    May 15, 2018 at 9:32 am #32054

    Hi RachelKHawkins,

    Can you please guide me how I can replicate this issue on my side? So i can easily to help you out.

    Thank you

    Post count: 8
    RachelKHawkins
    May 15, 2018 at 11:03 pm #32121

    Hi Adek,

    Thanks for the response. The way I originally found the cause of the issue was on my staging site. I noticed that the classic mode wasn’t working after updating our Jkreativ theme to the latest version (see screenshots in original post). I went through and deactivated each plugin then reactivated each one separately. None of the installed plugins caused the issue but the Jkreativ plugin. When I activated that specific plugin, the classic mode editor disappeared.

    I am using Jkreativ v2.4.4 and WP Bakery Page Builder v5.4.

    When I went to implement the fix suggested in the comment by Jegbagus, I had some trouble accessing the file through Filezilla and was presented with the Microsoft error message mentioned above. I had to find the original copy of the file as downloaded from Envato Market when we purchased the new theme, edit it with the fix, then upload that file onto the FTP server, replacing the one already on the site.

    Once I had done this (all still on the staging server), I went to test the page editor to see if the solution had worked. When I tried editing a page, the classic mode editor was still not showing up. On top of that, I experienced some irregularities with the Yoast plugin, as pictured above.

    I hope this answers your question. Please feel free to reach out if anything seems vague or if you have any other questions. I look forward to hearing from you.

    Post count: 2759
    Jegbagus
    May 22, 2018 at 9:37 am #32347

    hi RachelKHawkins

    please use this code, and put it on jkreativ themes > assets > css > global.css.
    this will force classic editor to show.

    Thank you

    Post count: 8
    RachelKHawkins
    May 31, 2018 at 11:14 pm #32630

    Hello All,

    This fix did not resolve the issue. I’m not sure what else to do at this point besides uninstall the theme and find a better solution.

    Do you have any other fix recommendations for this problem?

    Cheers,

    Rachel Hawkins

    Post count: 11196
    Adek
    June 4, 2018 at 3:38 pm #32810

    Hi RachelKHawkins,

    Sorry for the late reply.

    It seems I will need to do further investigation on your website. Can you please provide me login into the WP admin of your website? You can send it here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 8
    RachelKHawkins
    June 12, 2018 at 10:51 pm #33151
    This reply has been marked as private.
    Post count: 11196
    Adek
    June 19, 2018 at 1:35 pm #33343

    Hi RachelKHawkins,

    Thanks for your info but it seems you forget to provide the login URL on your website. Can you please provide it for us?

    Thank you

You must be logged in to reply to this topic.