Close

Account

Documentation

Forum

Menu

Blank ads for some Google Ad Manager (GPT) tags

  • Post count: 64
    tripledm
    October 1, 2018 at 8:04 pm #37626

    Hello,
    We use Google Ad Manager with Google Publishers tags so they are not the same as more Google Ads tags.
    For this we use the shortcode option and feed them in via a shortcode plugin.

    Since changing to Jnews we have had blank white ad slots in the sidebar ad positions. Not every load but some but it is getting worst.
    We have searched high and low and a contractor advised us that the theme’s built in Adsense support might be conflicting.

    Is it possible to turn off/disable the adsense or any adsense js that might always be loading. I have checked all the theme ad positions and none, inclusive of in widgets, are set to display adsense tags.

    I will post the URL with more details where it mostly occur in a private response.

    Thank you.

    Post count: 64
    tripledm
    October 1, 2018 at 8:08 pm #37627
    This reply has been marked as private.
    Post count: 10705
    Adek
    October 2, 2018 at 10:15 am #37652

    Hi tripledm,

    About disabling the built-in ads feature from JNews you just need to make sure all ad slot are disabled on the Customizer and make sure remove all JNews Ad Block element. For the built-in ads, we don’t use JavaScript. Let me know if you have further question.

    Thank you

    Post count: 64
    tripledm
    October 2, 2018 at 2:54 pm #37679

    Thank you I will have a look maybe skip all the theme ad slots and hard code them in via child theme.

    It would be awesome if you guys built in Google Ad Manager support and have a custom code option for PHP & Script to run from.

    Post count: 275
    Ferdy
    October 3, 2018 at 2:08 pm #37737

    Hi tripledm,

    Thank you for your suggestion, we’ll take a look at this thing for the future update.

    Thank you

    Post count: 64
    tripledm
    October 12, 2018 at 1:29 am #38120

    Ok so I found out it’s the sticky sidebar that causes the blank ads but now I cannot switch it off for /travel & /lifestyle categories. I disable it, change it to any other options I have tried everything no luck.

    When I disable the Detail Category Customizer & Extended Category Option then /lifestyle is all messed up and travel goes to default.

    Where does it store the customizer info in the tables/database? Maybe if I manually delete the custom entries it will clear but at the moment I cannot change anything, it does not even take global settings with the option for override off.

    Post count: 275
    Ferdy
    October 12, 2018 at 3:46 pm #38169

    Hi tripledm,

    I am not sure what the thing you want to achieve above. can you tell more detail so I can easily to help you?

    Thank you

    Post count: 64
    tripledm
    October 12, 2018 at 3:59 pm #38170

    I’m not sure how I can explain it better if you did not understand that…

    Detail Category Customizer & Extended Category Option (those are your plugins)

    (in private full URL is there)

    GO TO /travel (set to NOT override category settings)
    GO TO /lifestyle (set to NOT override category settings)
    GO TO / news or /business or /sport (set to NOT override category settings)

    NOTE that Travel & Lifestyle has a different header (two images next to each other) where Business, news, sport etc has different layout/more images.

    I CANNOT CHANGE any of the custom settings for Lifestyle or Travel, it just won’t change! It is stuck on those two images and with sticky sidebar on I CANNOT CHANGE the settings it does not change not in the preview nor does it save the changes.
    IF I disable Category Customizer plugin the Lifestyle ALL MESSED UP it’s got a left hand sidebar instead of right and grey background behind the category text and title.

    Where in the database are the settings for the Category Customizer plugin stored? How do I fix this as it’s messing up a live site and why does lifestyle mess up are there any demo configurations messing it up?

    • This reply was modified 1 week, 1 day ago by  tripledm.
    • This reply was modified 1 week, 1 day ago by  tripledm.
    Post count: 275
    Ferdy
    October 12, 2018 at 5:36 pm #38176

    Hi tripledm,

    It seems we need to do further investigation on your website. Can you please provide us with login access to your website? You can send it here and don’t forget to check Set as private reply option below.

    Thank you

    Post count: 64
    tripledm
    October 12, 2018 at 8:44 pm #38180
    This reply has been marked as private.
    Post count: 275
    Ferdy
    October 15, 2018 at 10:13 am #38209

    Hi tripledm,

    I’ve been checking your staging website. there is a mixed content issue on your staging website, You can see this screenshot. maybe on your live site have the same issue that makes the post action fail, so please make sure you have been set up the SSL on your site properly. in this case, please contact the server administrator of your site because this issue is related to server setup.

    Thank you

    Post count: 64
    tripledm
    October 15, 2018 at 4:28 pm #38236

    Hello, it’s not a mixed content issue if you looked at the live site and inspected element on the same page you would have seen that it’s not that. I have done a search and replace so staging everything is now on HTTPS and it’s not the cause of the problem.

    Some server errors worth mentioning:

    Heaps of line 47 errors for the theme on the server:

    PHP Warning: Invalid argument supplied for foreach() in /— server path — /wp-content/themes/jnews/class/ContentTag.php on line 47

    A few of these not as often but a few

    Class ‘JNews\\Archive\\IndexArchive’ not found in /— server path —/wp-content/themes/jnews/index.php:2\nStack trace:\n#0 {main}\n thrown in /— server path —/wp-content/themes/jnews/index.php on line 2

    one or two every hour of these

    PHP Warning: mysqli_query(): Error reading result set’s header in /— server path —/wp-includes/wp-db.php on line 1924

    Post count: 275
    Ferdy
    October 16, 2018 at 9:45 am #38251

    Hi tripledm,

    I’ve been checking again your website. I assume you were set the override setting on metabox section on the category menu, not on the customizer. Please check my screenshot (travel category, lifestyle category). in this case, if you have many categories I recommended to use JNews – Extended Category Option plugin and you can set on metabox section on the category menu. but if your category not to much you can use category option on customizer. let me know if you have further question.

    Thank you

    Post count: 64
    tripledm
    October 16, 2018 at 1:40 pm #38267

    Thank you I am sooo glad now. We have extended category option installed and have only been using that. The settings to override under categories we have never used so that must have transferred with the demo.

    Either way happy it’s fixed and found the cause thank you!

    Post count: 275
    Ferdy
    October 18, 2018 at 9:16 am #38308

    Glad to hear that tripledm, let me know if you have further question.

    Thank you

You must be logged in to reply to this topic.