Close

Account

Documentation

Forum

Menu

Analytics Infinite Scroll

  • Post count: 15
    michaelnorthcott1
    November 24, 2017 at 12:12 am #25881

    Hello,

    Infinite scroll activated in JNews, Google Analytics not registering new pageviews for each article scrolled.

    How do I ‘push’ the infinite scroll pageviews to Google Analytics using code?

    Post count: 10848
    Adek
    November 24, 2017 at 2:39 am #25907

    Hi michaelnorthcott1,

    May i know what the current JNews version that you use in there? Becuase on the version 1.0.2 of JNews (and later version) we have been fixed this issue.

    Thank you

    Post count: 15
    michaelnorthcott1
    December 6, 2017 at 8:12 pm #26446

    Hello,

    I am using the most up to date version of the theme for a new site at http://www.landscapeinsight.com (bought another licence) and it is appending “/autoload” to the URL, and this is then not registering on real time analytics records.

    Can you please advise?

    Post count: 12
    timeglass
    December 8, 2017 at 1:18 am #26470

    Hi there!
    I have the same problem. I’ve just purchased the theme (December, 7) and installed it and demo content.
    And when I’m scrolling certain post, then “/autoload” is being added at the end of the URL.
    I hope you guys will fix it as soon as possible.
    Thank you!

    Post count: 2751
    Jegbagus
    December 8, 2017 at 12:59 pm #26487

    hi guys, please use this code : https://pastebin.com/Ria7GSCu
    and replace code on wp-content > plugins > jnews-auto-load-post > jnews-auto-load-post.php

    Thank you

    Post count: 15
    michaelnorthcott1
    December 12, 2017 at 12:25 am #26539

    Hello,

    I have tried implementing this code. The /autoload has stopped appearing in the URL bar, but still nothing is registering on Google Analytics.

    Post count: 10848
    Adek
    December 12, 2017 at 9:09 am #26553

    Hi michaelnorthcott1,

    Currently, we still working on this issue and the fix will available on next theme update. Hopefully, we can release new theme update as soon. Please be patient for a while. Let us know if you need something else.

    Thank you

    Post count: 15
    michaelnorthcott1
    December 17, 2017 at 10:15 pm #26671
    This reply has been marked as private.
    Post count: 10848
    Adek
    December 18, 2017 at 9:22 am #26685

    Hi michaelnorthcott1,

    We just released a new version of JNews a few days ago, kindly you can check it out and we also updating several plugins in there including JNews Autoload Post.

    Thank you

    Post count: 15
    michaelnorthcott1
    December 18, 2017 at 7:52 pm #26698
    This reply has been marked as private.
    Post count: 10848
    Adek
    December 19, 2017 at 12:14 pm #26711

    Hi michaelnorthcott1,

    Can you please provide me your Google Analytic script? i will need to try replicate it directly on my side. You can send it here and don’t forget to check Set as private reply option below.

    Also, may i know if the analytics does not work only for the post that load by autoload post feature or including the post that you visit by using post URL?

    Thank you

    Post count: 15
    michaelnorthcott1
    December 19, 2017 at 9:52 pm #26725
    This reply has been marked as private.
    Post count: 10848
    Adek
    December 20, 2017 at 1:22 pm #26743

    Hi michaelnorthcott1,

    Previously i need Google Analytic script that you use on your site and replicate the issue on my side, because previously i think you’re not using a plugin in order to insert it into your website.

    Anyway, can you please try to replace the following file below and don’t forget to make a backup before doing the changes:
    1. /jnews/assets/js/main.js with this one https://pastebin.com/t27TN0Qw
    2. /jnews/assets/dist/frontend.min.js with this one https://pastebin.com/8WzHKANT

    Also, it seems you’re using JNews Speed and WP Super Cache plugin. Please try to clear all the cache from JNews Speed and WP Super Cache plugin (including your browser cache) after doing the changes on above. If the problem still persists, we will need to access your wp admin panel directly to do further investigating regarding this issue.

    Thank you

    Post count: 15
    michaelnorthcott1
    December 20, 2017 at 7:59 pm #26749
    This reply has been marked as private.
    Post count: 10848
    Adek
    December 21, 2017 at 10:49 am #26763

    Hi michaelnorthcott1,

    Thanks for your information. It seems i will need to change a certain file in there and do some further investigation. Can you please provide me access your server via FTP to upload the necessary file? Because if i do it from wp admin panel, i worry about max upload file limit.

    Looking forward to hearing from you.

    Thank you

You must be logged in to reply to this topic.